MobaLedLib: 768 LEDs, Servos, Sound, …………… Seit Anfang März mit eigenem Wiki

Bereich für alle Themen rund um Modellbahn-Software, sowie der nötigen Hardware (PCs, Bildschirme, etc.).

Railcar
InterRegio (IR)
Beiträge: 187
Registriert: Do 15. Nov 2018, 09:41
Alter: 67

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1876

Beitrag von Railcar »

Hi Christian,

die Libraries gehören in:

C:\Users\xxxxxx\Documents\Arduino\libraries

Statt xxxxxx gehört da eben dein Name hin.

Ulrich


Christian69
InterRegio (IR)
Beiträge: 162
Registriert: So 26. Mai 2013, 16:12
Nenngröße: N
Stromart: digital
Steuerung: RMX950USB, SLX852, TC 9.0 Gold
Gleise: Peco 55
Wohnort: Baden-Württemberg
Alter: 51
Kontaktdaten:
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1877

Beitrag von Christian69 »

Hallo Ulrich,

ok, habe diese in den Unterordner: libraries hinein kopiert
Bekomme aber immer noch diese Fehlermeldung:

" " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " "
" Zum "
" PC Prog_Generator Ver. 0.71 by Hardi "
" \\ "
" \\ "
" ____\\___________________ "
" | | [_] | | [_] |[oo] | Achtung: Es muss der linke "
" | | | | | | Arduino mit dem PC verbunden "
" | | | | | | sein. "
" | | LED | | | | "
" | | Nano| | | | Wenn alles gut geht, dann wird das "
" | | | | | | Fenster ohne eine weitere Meldung "
" | | | | | | geschlossen (Liest ja eh keiner). "
" | |_____| |_____| [O] | "
" | [@] [@] [@] | Falls Probleme auftreten, dann wird "
" |__________________[:::]__| das angezeigt. "
" "
" " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " "
Verzeichnis: C:\Users\Mercedes\Documents\Arduino\MobaLedLib_1.0.1\LEDs_AutoProg
Konfiguration wird geladen...
Pakete werden initialisiert...
Boards werden vorbereitet...
Überprüfungsvorgang...
In file included from C:\Users\Mercedes\Documents\Arduino\MobaLedLib_1.0.1\LEDs_
AutoProg\LEDs_AutoProg.ino:145:0:
LEDs_AutoProg.h:11:167: error: FastLED.h: No such file or directory
compilation terminated.
exit status 1

**********************************
* Da ist was schief gegangen ;-( * ERRORLEVEL 1
**********************************
Drücken Sie eine beliebige Taste . . .

Gruesse
Christian


soldier333
RegionalExpress (RE)
Beiträge: 62
Registriert: Di 29. Dez 2015, 19:06
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1878

Beitrag von soldier333 »

Hallo,

das bezieht sich auf den ersten Versuch mit der Hauptplatine, irgendwie muss man ja mal Anfangen nach dem löten.
Also über USB an den PC dann Excel mit dem Prog Generator gestartet.
Angezeigt wird die Bsp 1 (RGB Heartbead), dann Knopf zum Arduino schicken gedrückt, nichts passiert, außer die Fehlermeldung.

Im Wiki versucht irgendwas zu finden, auch nix darüber gefunden.

Jetzt steht der Laie da und wundert sich, weiß nicht wie denn weiter.
Wo ist denn der Fehler?

Gruß

Peter


Railcar
InterRegio (IR)
Beiträge: 187
Registriert: Do 15. Nov 2018, 09:41
Alter: 67

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1879

Beitrag von Railcar »

@ Christian

Wie hast du die Fastled.lib installiert? Über den Bibliotheksverwalter oder kopiert?

@ Peter

Befindet sich die Arduino_debug im gleichen Verzeichnis wie die Arduino.exe?

Ulrich


soldier333
RegionalExpress (RE)
Beiträge: 62
Registriert: Di 29. Dez 2015, 19:06
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1880

Beitrag von soldier333 »

Hallo Ulrich,

ja befinden sich beide im gleichen Verzeichnis. Allerdings nicht auf C:

Gruß

Peter


Moba_Nicki
InterRegio (IR)
Beiträge: 167
Registriert: Di 28. Jan 2020, 18:24
Nenngröße: H0
Stromart: divers
Steuerung: Steuerung im Eigenbau
Gleise: M-Gleis, Spur Z
Wohnort: Nördliches Oberbayern
Alter: 38
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1881

Beitrag von Moba_Nicki »

Hallo Peter

die Arduinoumgebung muss explizit auf C: im Standardverzeichnis installiert werden. Die Verwendung eines anderen Pfades ist aktuell noch nicht möglich.

Schöne Grüße
Dominik
Alle Infos zur MobaLedLib findet ihr hier: https://wiki.mobaledlib.de/


soldier333
RegionalExpress (RE)
Beiträge: 62
Registriert: Di 29. Dez 2015, 19:06
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1882

Beitrag von soldier333 »

Hallo Dominik,

also komplett neu installieren, oder gibt's einen anderen Weg?

Um die ganzen bereits zusätzlich installierten Bibliotheken zu behalten.

Gruß

Peter


Christian69
InterRegio (IR)
Beiträge: 162
Registriert: So 26. Mai 2013, 16:12
Nenngröße: N
Stromart: digital
Steuerung: RMX950USB, SLX852, TC 9.0 Gold
Gleise: Peco 55
Wohnort: Baden-Württemberg
Alter: 51
Kontaktdaten:
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1883

Beitrag von Christian69 »

Hallo Ulrich,

ich habe nun alles noch einmal neu installiert und die Fehlermeldungen sind nun noch umfangreicher als vorher.


" " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " "
" Zum "
" PC Prog_Generator Ver. 0.62 by Hardi "
" \\ "
" \\ "
" ____\\___________________ "
" | | [_] | | [_] |[oo] | Achtung: Es muss der linke "
" | | | | | | Arduino mit dem PC verbunden "
" | | | | | | sein. "
" | | LED | | | | "
" | | Nano| | | | Wenn alles gut geht, dann wird das "
" | | | | | | Fenster ohne eine weitere Meldung "
" | | | | | | geschlossen (Liest ja eh keiner). "
" | |_____| |_____| [O] | "
" | [@] [@] [@] | Falls Probleme auftreten, dann wird "
" |__________________[:::]__| das angezeigt. "
" "
" " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " " "
Verzeichnis: C:\Users\Mercedes\Documents\Arduino\MobaLedLib_0.9.3\LEDs_AutoProg
Konfiguration wird geladen...
Pakete werden initialisiert...
Boards werden vorbereitet...
Überprüfungsvorgang...
In file included from C:\Users\Mercedes\Documents\Arduino\MobaLedLib_0.9.3\LEDs_
AutoProg\LEDs_AutoProg.ino:145:0:
sketch\LEDs_AutoProg.h: In function 'int MobaLedLib_Configuration()':
LEDs_AutoProg.h:31:16: error: 'SI_1' was not declared in this scope
EndCfg // End of the configuration
^
LEDs_AutoProg.h:31:22: error: 'GAS_LIGHT' was not declared in this scope
EndCfg // End of the configuration
^
LEDs_AutoProg.h:31:44: error: 'GAS_LIGHTD' was not declared in this scope
LEDs_AutoProg.h:31:87: error: 'GasLights' was not declared in this scope
In file included from C:\Users\Mercedes\Documents\Arduino\MobaLedLib_0.9.3\LEDs_
AutoProg\LEDs_AutoProg.ino:145:0:
sketch\LEDs_AutoProg.h: At global scope:
LEDs_AutoProg.h:38:23: error: variable or field 'Set_Start_Values' declared void

LEDs_AutoProg.h:38:23: error: 'MobaLedLib_C' was not declared in this scope
LEDs_AutoProg.h:38:37: error: 'MobaLedLib' was not declared in this scope
LEDs_AutoProg:183:1: error: 'CRGB' does not name a type
CRGB leds[NUM_LEDS]; // Define the array of leds
^
LEDs_AutoProg:185:18: error: expected constructor, destructor, or type conversio
n before '(' token
MobaLedLib_Create(leds); // Define the MobaLedLib instance
^
LEDs_AutoProg:186:1: error: 'LED_Heartbeat_C' does not name a type
LED_Heartbeat_C LED_HeartBeat(LED_HEARTBEAT_PIN); // Initialize the heartbeat L
ED which is flashing if the program runs.
^
C:\Users\Mercedes\Documents\Arduino\MobaLedLib_0.9.3\LEDs_AutoProg\LEDs_AutoProg
.ino: In function 'void Proc_Color_Cmd(const char*)':
LEDs_AutoProg:203:12: error: 'leds' was not declared in this scope
leds.r = r;
^
LEDs_AutoProg:207:8: error: 'FastLED' was not declared in this scope
FastLED.show(); // Show the LEDs (send the leds[]
array to the LED stripe)
^
C:\Users\Mercedes\Documents\Arduino\MobaLedLib_0.9.3\LEDs_AutoProg\LEDs_AutoProg
.ino: In function 'void Receive_LED_Color_per_RS232()':
LEDs_AutoProg:226:6: error: 'LED_HeartBeat' was not declared in this scope
LED_HeartBeat.Update(300); // Fast Flash
^
C:\Users\Mercedes\Documents\Arduino\MobaLedLib_0.9.3\LEDs_AutoProg\LEDs_AutoProg
.ino: In function 'void setup()':
LEDs_AutoProg:571:3: error: 'FastLED' was not declared in this scope
FastLED.addLeds<NEOPIXEL, LED_DO_PIN>(leds, NUM_LEDS); // Initialize the Fast
LED library
^
LEDs_AutoProg:571:19: error: 'NEOPIXEL' was not declared in this scope
FastLED.addLeds<NEOPIXEL, LED_DO_PIN>(leds, NUM_LEDS); // Initialize the Fast
LED library
^
LEDs_AutoProg:571:41: error: 'leds' was not declared in this scope
FastLED.addLeds<NEOPIXEL, LED_DO_PIN>(leds, NUM_LEDS); // Initialize the Fast
LED library
^
LEDs_AutoProg:606:20: error: 'MobaLedLib' was not declared in this scope
Set_Start_Values(MobaLedLib); // The start values are defined in the "MobaLed
Lib.h" file if entered by the user
^
LEDs_AutoProg:606:30: error: 'Set_Start_Values' was not declared in this scope
Set_Start_Values(MobaLedLib); // The start values are defined in the "MobaLed
Lib.h" file if entered by the user
^
C:\Users\Mercedes\Documents\Arduino\MobaLedLib_0.9.3\LEDs_AutoProg\LEDs_AutoProg
.ino: In function 'void loop()':
LEDs_AutoProg:644:3: error: 'LED_HeartBeat' was not declared in this scope
LED_HeartBeat.Update();
^
LEDs_AutoProg:646:3: error: 'MobaLedLib' was not declared in this scope
MobaLedLib.Update(); // Update the LEDs in the configuration

^
LEDs_AutoProg:665:3: error: 'FastLED' was not declared in this scope
FastLED.show(); // Show the LEDs (send the leds[] array
to the LED stripe)
^
exit status 1

**********************************
* Da ist was schief gegangen ;-( * ERRORLEVEL 1
**********************************
Drücken Sie eine beliebige Taste . . .

Ich weiß nicht was ich falsch mache!
Grüße
Christian


Saryk
InterCity (IC)
Beiträge: 588
Registriert: So 27. Okt 2019, 21:38
Nenngröße: H0
Stromart: digital
Kontaktdaten:
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1884

Beitrag von Saryk »

Hej Christian,
das erste was ich aus dem Error-Log lesen kann ist: Viele Variablen sind nicht gesetzt bzw. nicht mit einer Value versehen, was dein Projekt dazu bringt Fehler zu akkumullieren.

grüße,
Sarah
kiek nich so!
Ungarn, per Bahn || Ideenkiste


Railcar
InterRegio (IR)
Beiträge: 187
Registriert: Do 15. Nov 2018, 09:41
Alter: 67

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1885

Beitrag von Railcar »

Hi Christian,
In file included from C:\Users\Mercedes\Documents\Arduino\MobaLedLib_0.9.3\LEDs_
AutoProg\LEDs_AutoProg.ino:145:0:
sketch\LEDs_AutoProg.h: In function 'int MobaLedLib_Configuration()':
Gibts bei dir nen Ordner sketch - bist du sicher das du nach der Anleitung im Wiki

https://wiki.mobaledlib.de/anleitungen/quickstart installiert hast?

Deine Fehlermeldungen sehen aus als ob einige Dateien / Libraries nicht in den Verzeichnissen liegen in denen sie sollen.

Ulrich


Christian69
InterRegio (IR)
Beiträge: 162
Registriert: So 26. Mai 2013, 16:12
Nenngröße: N
Stromart: digital
Steuerung: RMX950USB, SLX852, TC 9.0 Gold
Gleise: Peco 55
Wohnort: Baden-Württemberg
Alter: 51
Kontaktdaten:
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1886

Beitrag von Christian69 »

Hallo Sarah,

ich habe lediglich ein Projekt aus der Excel-File (Prog Generator)- Animiertes Haus - verwendet und 3 Räume mit LEDs ausgewählt und geladen.
Laut Wiki sollte dies doch ohne weiteres funktionieren. Gibt es ein einfaches File, um die Soft- und Hardware zu testen?
Wie gesagt mit dem "Blink" haben beide Nanos funktioniert und auch auf den SX Nano konnte ich die Software ohne Probleme installieren.

Der Ordner sketch befindet sich bei mir unter Benutzer/Name/AppData/Ardunio_build_LED_AutoProg

Grüße
Christian
Zuletzt geändert von Christian69 am Fr 10. Apr 2020, 18:20, insgesamt 2-mal geändert.


Christian69
InterRegio (IR)
Beiträge: 162
Registriert: So 26. Mai 2013, 16:12
Nenngröße: N
Stromart: digital
Steuerung: RMX950USB, SLX852, TC 9.0 Gold
Gleise: Peco 55
Wohnort: Baden-Württemberg
Alter: 51
Kontaktdaten:
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1887

Beitrag von Christian69 »

Hallo Ulrich,

ich hatte exakt nach der Anleitung installiert und um zu prüfen, ob irgendwelche Dateien nicht mit installiert wurden, müsste ich wissen, welche Dateien in welchen Ordnerstrukturen sich befinden müssen. Leider sagt dazu das Wiki nichts aus. Also ist das ganze doch nur für IT Spezialisten.

Grüße
Christian


Railcar
InterRegio (IR)
Beiträge: 187
Registriert: Do 15. Nov 2018, 09:41
Alter: 67

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1888

Beitrag von Railcar »

Hi Christian,

mal ganz dumm gefragt - du verwendest auch eine aktuelle Microsoft Excel Version?

Ulrich


Christian69
InterRegio (IR)
Beiträge: 162
Registriert: So 26. Mai 2013, 16:12
Nenngröße: N
Stromart: digital
Steuerung: RMX950USB, SLX852, TC 9.0 Gold
Gleise: Peco 55
Wohnort: Baden-Württemberg
Alter: 51
Kontaktdaten:
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1889

Beitrag von Christian69 »

Hallo Ulrich,

ja :-)

Excel 2010.

Grüße
Christian


Moba_Nicki
InterRegio (IR)
Beiträge: 167
Registriert: Di 28. Jan 2020, 18:24
Nenngröße: H0
Stromart: divers
Steuerung: Steuerung im Eigenbau
Gleise: M-Gleis, Spur Z
Wohnort: Nördliches Oberbayern
Alter: 38
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1890

Beitrag von Moba_Nicki »

Christian69 hat geschrieben:
Fr 10. Apr 2020, 16:43
.....
Prog_Generator Ver. 0.62
....
Verzeichnis: C:\Users\Mercedes\Documents\Arduino\MobaLedLib_0.9.3\LEDs_AutoProg

....
Hallo Christian
so wie ich das sehe verwendest du eine veraltete Version der MobaLedLib.
Bitte aktualisiere die MobaLedLib über die Bibliotheksverwaltung der Arduino IDE auf die aktuelle Version 1.0.1

aktuell verwendete Versionen
  • Ardunio: 1.8.9
  • MobaLedLib: 1.0.1
  • FastLED: 3.3.2
  • NMRA DCC: 2.0.0
  • Programm Generator: 0.71
  • Pattern Configurator: 0.92

Schöne Grüße
Dominik
Zuletzt geändert von Moba_Nicki am Fr 10. Apr 2020, 18:34, insgesamt 1-mal geändert.
Alle Infos zur MobaLedLib findet ihr hier: https://wiki.mobaledlib.de/


Moba_Nicki
InterRegio (IR)
Beiträge: 167
Registriert: Di 28. Jan 2020, 18:24
Nenngröße: H0
Stromart: divers
Steuerung: Steuerung im Eigenbau
Gleise: M-Gleis, Spur Z
Wohnort: Nördliches Oberbayern
Alter: 38
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1891

Beitrag von Moba_Nicki »

soldier333 hat geschrieben:
Fr 10. Apr 2020, 16:36
Hallo Dominik,

also komplett neu installieren, oder gibt's einen anderen Weg?

Um die ganzen bereits zusätzlich installierten Bibliotheken zu behalten.

Gruß

Peter
Hallo Peter
du musst die gesamte IDE deinstallieren und danach neu installieren.
Die saubere Lösung für die Bibliotheken wäre, damnach alles über die Arduino-IDE neu zu installieren um auch alle auf einem aktuellen gleichen Stand wie wir zu haben.

Du kannst aber auch vor der Deinstallation den Ordner "C:\Users\[BENUTZERNAME]\Documents\Arduino\libraries" kopieren und danach wieder reinkopieren und verwenden. Allerdings werden dann evtl vorhanden Fehler mitübernommen.

Schöne Grüße
Dominik
Alle Infos zur MobaLedLib findet ihr hier: https://wiki.mobaledlib.de/


4fangnix
RegionalExpress (RE)
Beiträge: 98
Registriert: So 18. Okt 2015, 12:26
Nenngröße: H0
Stromart: digital
Steuerung: Rocrail / DCC BiDiB
Gleise: C-Gleis
Wohnort: Weiterstadt
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1892

Beitrag von 4fangnix »

Hallo Christian,

der Beginn des Wiki stammt von Anfang März 2020 und ist weiterhin noch im Aufbau.
Dafür ist es nach meiner Ansicht schon recht umfangreich.
Ich hoffe, mit Hilfe des Forums bekommen wir Dein Problem behoben. Ich bin selbst auch kein IT-Spezialist und habe es hinbekommen.
Hallo Christian
so wie ich das sehe verwendest du eine veraltete Version der MobaLedLib.
Bitte aktualisiere die MobaLedLib über die Bibliotheksverwaltung der Arduino IDE auf die aktuelle Version 1.0.1
Dort solltest Du auch die FastLED library einbinden können, siehe auch Forum-Beitrag #825.

Schöne Grüße
Armin
Rocrail, 1x OpenDCC GBMboost, 1x BiDiB RF-Basis (OpenCar), 5x GBM16T, 2x LightControl, 2x OneControl, 5x Mobalist, DMX-RGB-Dimmer, MobaLedLib mit >60 Stück WS2811/WS2812 RGB-LED, Intellibox - Märklin C- und K-Gleis, Bahn im Aufbau.


Saryk
InterCity (IC)
Beiträge: 588
Registriert: So 27. Okt 2019, 21:38
Nenngröße: H0
Stromart: digital
Kontaktdaten:
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1893

Beitrag von Saryk »

Da ich den beitrag gerade nicht finde
Moba_Nicki hat geschrieben:
Fr 10. Apr 2020, 18:29
[videoeinbindungsplatzhalterchen]
Hej Nick,
Ich hoffe, der Wiki Eintrag weißt so zu gefallen. Ich möchte da keinen Roman über die potenziellen Gefahren von Strom schreiben, weil den sollte wenn der Elektroheini wissen, nicht unser 08/15-Modellbauer, der seine Anlage verkabeln möchte.

grüße,
Sarah
kiek nich so!
Ungarn, per Bahn || Ideenkiste


Christian69
InterRegio (IR)
Beiträge: 162
Registriert: So 26. Mai 2013, 16:12
Nenngröße: N
Stromart: digital
Steuerung: RMX950USB, SLX852, TC 9.0 Gold
Gleise: Peco 55
Wohnort: Baden-Württemberg
Alter: 51
Kontaktdaten:
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1894

Beitrag von Christian69 »

Hallo Armin,

danke, genau das war mein Problem.

Bei mir lautete der Eintrag „Arduino AVR Boards…“ installierte Version 1.6.23
Nach dem Update auf 1.8.2 war der Fehler behoben. Die Excel habe ich auf die neueste Version 1.0.1 updatet.

Danke und Grüße
Christian


soldier333
RegionalExpress (RE)
Beiträge: 62
Registriert: Di 29. Dez 2015, 19:06
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1895

Beitrag von soldier333 »

Hallo Dominik,
nach der Neuinstallation, bekomme ich eine Menge Fehlermeldungen.
Das Hochladen vom Sketch hat nicht geklappt.

Gruß

Peter


Moba_Nicki
InterRegio (IR)
Beiträge: 167
Registriert: Di 28. Jan 2020, 18:24
Nenngröße: H0
Stromart: divers
Steuerung: Steuerung im Eigenbau
Gleise: M-Gleis, Spur Z
Wohnort: Nördliches Oberbayern
Alter: 38
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1896

Beitrag von Moba_Nicki »

Saryk hat geschrieben:
Fr 10. Apr 2020, 18:52
Da ich den beitrag gerade nicht finde
Moba_Nicki hat geschrieben:
Fr 10. Apr 2020, 18:29
[videoeinbindungsplatzhalterchen]
Hej Nick,
Ich hoffe, der Wiki Eintrag weißt so zu gefallen. Ich möchte da keinen Roman über die potenziellen Gefahren von Strom schreiben, weil den sollte wenn der Elektroheini wissen, nicht unser 08/15-Modellbauer, der seine Anlage verkabeln möchte.

grüße,
Sarah
Hallo Sarah
der Eintrag sieht doch schon sehr gut aus.
:gfm:
Vielen Dank für deine Arbeit und natürlich aucb aller Anderen die fleißig an der Wiki und Dokumentationen arbeiten und natürlich Ihr Wissen und ihre Entwicklungen besteuern und so allen helfen.

Viele dankende Grüße
Dominik
Alle Infos zur MobaLedLib findet ihr hier: https://wiki.mobaledlib.de/


Moba_Nicki
InterRegio (IR)
Beiträge: 167
Registriert: Di 28. Jan 2020, 18:24
Nenngröße: H0
Stromart: divers
Steuerung: Steuerung im Eigenbau
Gleise: M-Gleis, Spur Z
Wohnort: Nördliches Oberbayern
Alter: 38
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1897

Beitrag von Moba_Nicki »

soldier333 hat geschrieben:
Fr 10. Apr 2020, 19:12
Hallo Dominik,
nach der Neuinstallation, bekomme ich eine Menge Fehlermeldungen.
Das Hochladen vom Sketch hat nicht geklappt.

Gruß

Peter
Hallo Peter
kannst du uns bitte die Fehlermeldungen kopieren und hier einfügen. Dann können wir schauen, wo es hakt.
Nur eines vorab. Hast du alle Bibliotheken installiert die notwendig sind?
aktuell verwendete Versionen

Ardunio: 1.8.9
MobaLedLib: 1.0.1
FastLED: 3.3.2
NMRA DCC: 2.0.0
Bitte auch den Eintrag hier beachten
https://wiki.mobaledlib.de/anleitungen/ ... en/fastled

Schöne Grüße
Dominik
Alle Infos zur MobaLedLib findet ihr hier: https://wiki.mobaledlib.de/


soldier333
RegionalExpress (RE)
Beiträge: 62
Registriert: Di 29. Dez 2015, 19:06
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1898

Beitrag von soldier333 »

Hallo Dominik,

bei FastLED habe ich 3.3.3 installierd nicht die ältere 3.3.2, muss ich das auch wieder ändern?

Die anderen Dateien habe ich.

Was ich noch nicht begriffen habe, das mit den beiden Nano's. Wann und wie und wie lange werden diese in die Hauptplatine gesteckt?

Bei dem linken Nano blinkt die rote "L" ständig, ist das normal ?

Wie kann ich beide Nano nochmal von neuem flashen? Neustart nochmal? Eigentlich soll ja ein Nano und die MCP Platine eingesteckt werden.
Es soll ja der Merg-Bus mit den GCA Platinen verwendet werden.

Gruß
Peter


Moba_Nicki
InterRegio (IR)
Beiträge: 167
Registriert: Di 28. Jan 2020, 18:24
Nenngröße: H0
Stromart: divers
Steuerung: Steuerung im Eigenbau
Gleise: M-Gleis, Spur Z
Wohnort: Nördliches Oberbayern
Alter: 38
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1899

Beitrag von Moba_Nicki »

Hallo Peter

welche Fehlermeldung kommt denn bei dir?

Das blinken bei dem linken Arduino ist normal.
Den rechten Arduino brauchst du nicht, da kommt das CAN-Modul an dessen stelle, so wie in der Wiki beschrieben.
https://wiki.mobaledlib.de/anleitungen/ ... latine_can

Welche Version der Arduino Boards hast du installiert. Die FastLed erfordert mindestens Version 1.8.1 Aktuell ist 1.8.2.
siehe hier

Schöne Grüße
Dominik
Alle Infos zur MobaLedLib findet ihr hier: https://wiki.mobaledlib.de/


soldier333
RegionalExpress (RE)
Beiträge: 62
Registriert: Di 29. Dez 2015, 19:06
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Das beste an der MobaLedLib seid IHR! <3

#1900

Beitrag von soldier333 »

Hallo Dominik,

das ist mal wieder Technik die begeistert.

Boards Version ist die aktuelle 1.8.2

Jetzt, nach dem x. Versuch hat es scheinbar geklappt mit dem Hochladen.

Der blaue Text ist verschwunden. Keine Fehlermeldung mehr.

Wie gesagt, die rote "L" und eine RGB Led blinken bzw. wechseln die Farbe.

Wie mache ich jetzt weiter? Einige RGB LED mit Kabel anschließen nach Anleitung?
Oder die Verteilplatine anschließen?

Danke

Gruß
Peter

Antworten

Zurück zu „Software und Hardware“