MobaLedLib: 768 LEDs, Servos, Sound, …………… Seit Anfang März mit eigenem Wiki

Bereich für alle Themen rund um Modellbahn-Software, sowie der nötigen Hardware (PCs, Bildschirme, etc.).

aftpriv
InterCity (IC)
Beiträge: 889
Registriert: Di 3. Apr 2012, 10:01
Nenngröße: H0
Stromart: digital
Steuerung: Gleisbox+RocRail-RN-Node
Gleise: K-Gleis|:|(3-Leiter)
Wohnort: 636xx Hessen/Main-Kinzig-Kreis
Alter: 69

Preisliste

#1001

Beitrag von aftpriv »

Baustelle aktuelles
Pickel-Bahner seit 1958 / K-Gleis + ZIMO-Decoder (MX633P22/MX645P22)
RocRail & RocNetNode
Email bezüglich MobaLedLib-Belange: LedLib@yahoo.com


WolfHo
RegionalExpress (RE)
Beiträge: 68
Registriert: Do 10. Okt 2019, 18:41
Nenngröße: N
Stromart: digital
Steuerung: Intellibox, Railware, Arduino
Gleise: Arnold
Wohnort: Dietzenbach
Alter: 74
Deutschland

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... ist ein Jahr alt

#1002

Beitrag von WolfHo »

Hallo Hardi,

als Bestätigung: vor einer halben Stunde habe ich die neue Version des Pattern Configurators erhalten, nicht aber die des Prog Generators.

Gruß Wolf
SpurN Arnold Gleis 60 m, Anlage 2,50x0,70 m, Sbhf 16 Gl., Bhf 7 Gl., BW mit Drehscheibe, 50 Loks, Epoche 3, Fahren IBox I Com2, Booster LDT DB-4; Schalten S-DEC-4, WDECN-TN; Melden HSI-88 (Com3), RM-GB-8(-N). Steuerung Railware 7.34, PC: Core i5 750 , 8 GB RAM, Win10 pro 64Bit


Mark
Regionalbahn (RB)
Beiträge: 31
Registriert: Di 15. Jan 2019, 21:21
Nenngröße: H0
Stromart: digital
Steuerung: FMZ
Gleise: Fleischmann
Wohnort: Rhoihesse

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1003

Beitrag von Mark »

Hallo Hardi,

kurz vor drei, 18.01.2020, das Update ist in der Arduino IDE noch nicht angekommen.

Rein theoretische Frage:
Um das Update von Github aus aufzuspielen müsste doch eigentlich nur der komplette Ordner als Zip-Download in
Documents\Arduino\libraries\MobaLedLib
entpackt werden, oder?

Und wie war das dann nochmal mit dem Prog_Gen und dem Pattern_Configurator und dem Color Tool im Ordner
Documents\Arduino\MobaLedLib_x.x.x ?
Wurde dieser Ordner mit allen Inhalten nicht automatisch erstellt? Bei welcher Aktion nochmal?
Sorry, ich bin etwas vergesslich ;-)
Mark


WolfHo
RegionalExpress (RE)
Beiträge: 68
Registriert: Do 10. Okt 2019, 18:41
Nenngröße: N
Stromart: digital
Steuerung: Intellibox, Railware, Arduino
Gleise: Arnold
Wohnort: Dietzenbach
Alter: 74
Deutschland

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1004

Beitrag von WolfHo »

Hallo Hardi,

habe jetzt gerade den Prog-Generator als Version 0.71 downgeloaded bekommen, ist das i.O.? Pattern Configurator ist 0.90 (Library 1.0.1).

Gruß Wolf
Zuletzt geändert von WolfHo am Sa 18. Jan 2020, 10:54, insgesamt 2-mal geändert.
SpurN Arnold Gleis 60 m, Anlage 2,50x0,70 m, Sbhf 16 Gl., Bhf 7 Gl., BW mit Drehscheibe, 50 Loks, Epoche 3, Fahren IBox I Com2, Booster LDT DB-4; Schalten S-DEC-4, WDECN-TN; Melden HSI-88 (Com3), RM-GB-8(-N). Steuerung Railware 7.34, PC: Core i5 750 , 8 GB RAM, Win10 pro 64Bit


rolfha
InterRegio (IR)
Beiträge: 195
Registriert: Do 14. Feb 2019, 22:20
Nenngröße: N
Stromart: digital
Steuerung: Lenz
Gleise: Fleischmann
Wohnort: Kronberg
Alter: 70
Deutschland

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1005

Beitrag von rolfha »

Hallo Hardi,
was für eine Arbeit! Die Charlyplexing Grundlagenarbeit/Weiterentwicklung war sicher spannend aber auch sehr anstrengend. Ich muss jetzt echt meine alte Kiste mit den N-Signalen suchen und versuchen, die Umzubauen. Das Laden der Daten über die WS2811 Leitung ist der Wahnsinn.
Danke, dass du dein Gehirnschmalz für uns alle hier verbrätst.
Ich kann bei Manage Libraries die 1.0.0 und die 1.0.1 zum Update auswählen, habe es aber noch nicht gemacht. Ich möchte Sicherheitshalber meine Daten selber in andere Verzeichnisse kopieren. Das mache ich hoffentlich heute Abend.

Viele Grüße und Danke, Danke, Danke
Rolf

Benutzeravatar

franz_H0m
InterRegio (IR)
Beiträge: 210
Registriert: So 2. Nov 2008, 20:29
Nenngröße: H0m
Stromart: digital
Steuerung: DCC Eigenbau/Nachbau
Gleise: Tillig/Eigenbau
Wohnort: Lund, Schweden
Alter: 46
Schweden

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1006

Beitrag von franz_H0m »

Hallo Hardi und alle, die hier mitentwickeln,

:gfm: :gfm: :gfm: :gfm:

unglaublich! Auf meiner geplanten Anlage mit Motiven aus den Schweizer Bergen brauche ich zwar eigentlich kein Licht, aber jetzt überlege ich ernsthaft, sie nach Las Vegas zu verlegen :fool:

Und meine Signale haben auch nur drei Lichter. Wobei, mit Vorsignal am gleiche Mast sind das schon sieben 8) - da muss ich wohl mal RhB-Signale in 3D zeichnen... (ist nicht als Versprechen zu sehen, die Zeit... :roll: )
Grüße, Franz

Avatar: MAN-Zugmaschine der Ottensener Industriebahn.
Foto: Dr. Ullrich Huckfeld.

PS: Manche meiner Links sind z.Z. tot und manche Bilder werden nicht gezeigt, weil ich meine Homepage wegen der GDPR vorübergehend vom Netz genommen habe...


Railcar
InterRegio (IR)
Beiträge: 187
Registriert: Do 15. Nov 2018, 09:41
Alter: 67

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1007

Beitrag von Railcar »

Hi Hardi,

ich weiss daß wir das hier alle nur als Hobby betreiben, aber du solltest dir trotzdem mal ein 64bit System zulegen..... oder deine Beta tester sollten mal auf einem 64 bit System testen.

Bild

Ulrich

Benutzeravatar

Threadersteller
Hardi
InterCity (IC)
Beiträge: 672
Registriert: Mo 28. Dez 2015, 13:07
Nenngröße: H0
Stromart: digital
Steuerung: MS2 + IR, Eigenbau
Gleise: Märklin C-Gleis
Wohnort: Mainz
Alter: 56
Deutschland

Die neue Version 1.0.1 der MobaLedLib ist endlich verfügbar

#1008

Beitrag von Hardi »

Hallo Mark, Hallo sehnsüchtig Wartende,

Mir wurde die neue Version 1.0.1 der MobaLedLib Bibliothek bereits um 0:15 Uhr anzeigt. Das muss man aber akiv machen:

Man drückt STRG+Umschalten+I in der Arduino IDE gleichzeitig. Das geht auch über das Menü: „Werkzeuge/Bibliotheken verwalten…“
Bild

Eingabe von „moba“ in das Suchfeld rechts oben und in den gefundenen Eintrag klicken, dann erscheint der "Installieren" oder "Update" Button. Mann kann auch vorher die gewünschte Version auswählen (Unten links):
Bild

Wenn die Installation abgeschlossen ist (Dauert nur wenige Sekunden bei mir) drückt man die WIN+r Taste gleichzeitig. In den sich öffnenden „Ausführen“ Dialog kopiert man diese Zeile:

Code: Alles auswählen

%USERPROFILE%\Documents\Arduino\libraries\Mobaledlib\extras\Prog_Generator_MobaLedLib.xlsm
Damit wird die neueste Version des Prog_Generators 0.71 gestartet.

Jedes Programm hat eine eigne Versionsnummer. Die Bibliothek hat die Version 1.0.1. Der Pattern_Configurator die Version 0.91 und der Farbkasten die 1.26. Das mag zunächst verwirrend klingen ist aber ein übliches Verfahren. Wenn man bei jeder Änderung eines Teils die Versionsnummern aller dazugehörenden Komponenten erhöhen wollte, dann währe man schnell bei der Version 1000.
WolfHo hat geschrieben:
Sa 18. Jan 2020, 10:15
habe jetzt gerade den Prog-Generator als Version 0.71 downgeloaded bekommen, ist das i.O.? Pattern Configurator ist 0.90 (Library 1.0.1).
Komisch, eigentlich sollte der Pattern_Configurator die Version 0.91 haben.

Mark hat geschrieben:
Sa 18. Jan 2020, 02:54
Rein theoretische Frage:
Um das Update von Github aus aufzuspielen müsste doch eigentlich nur der komplette Ordner als Zip-Download in
Documents\Arduino\libraries\MobaLedLib
entpackt werden, oder?
Man kann die Bibliothek auch von Hand installieren. Das ist dann sinnvoll, wenn ich eine kleine Änderung (unwichtige) mache ohne gleich eine neue Version zu vergeben (Ich bin der Meinung, dass zu viele verschiedene Versionen verwirrend sind.).
Wenn man die Bibliothek von GitHub heruntergeladen hat, dann landet sie meistens im „Downloads“ Ordner (Abhängig von den persönlichen Einstellungen). Dort hat sie aber den Namen „MobaLedLib-master.zip“.
So eine ZIP Datei kann auch über die Arduino IDE installiert werden:
Bild
In dem folgenden Dialog wechselt man in das „Downloads“ Verzeichnis und klickt auf die heruntergeladene Datei. Es kann sein, dass dort mehrere durchnummerierte Dateien liegen, wenn man das mehrfach gemacht hat. Dann nimmt man die mit der größten Nummer.

Mark hat geschrieben:
Sa 18. Jan 2020, 02:54
Und wie war das dann nochmal mit dem Prog_Gen und dem Pattern_Configurator und dem Color Tool im Ordner
Documents\Arduino\MobaLedLib_x.x.x ?
Wurde dieser Ordner mit allen Inhalten nicht automatisch erstellt? Bei welcher Aktion nochmal?
Ja, der Ordner wird automatisch erstellt. Für jede neue Version wird ein eigener Ordner erstellt.
Bild
Damit hat man die Möglichkeit die Eingaben im Excel von der alten Version in die neue zu kopieren. Es kann sein, dass man den Arduino von der alten Version aus nicht mehr programmieren kann, aber Eure Eingaben sollten sicher in dem alten Ordner stehen.

Es schadet aber nicht, wenn man die Dateien noch mal von Hand kopiert, aber eigentlich werden die alten Eingaben nicht überschrieben oder gelöscht:
rolfha hat geschrieben:
Sa 18. Jan 2020, 10:47
Ich kann bei Manage Libraries die 1.0.0 und die 1.0.1 zum Update auswählen, habe es aber noch nicht gemacht. Ich möchte Sicherheitshalber meine Daten selber in andere Verzeichnisse kopieren.
Die Eingaben im Prog_Generator werden über die Zwischenablage von der alten in die neue Version kopiert. Beim Pattern_Configurator kann man die Blätter über das Menu in eine Datei Speichern und dann im neuen Programm wieder importieren. Dabei können mehrere Blätter auf einmal gesichert/geladen werden.
Die Version 1.0.0 Der Bibliothek ist Fehlerhaft ;-( Hier wurden nicht alle neuen Programme hochgeladen. Es war einfach zu spät als ich das Zeug hochgeladen habe.

Nach dem ersten Start der Programme werden Links zum Starten auf dem Windows Desktop angelegt:
Bild
Darüber werden die Programme dann gestartet. Wenn man noch mal den Weg über WIN+r geht wird eine Kopie des Programms mit einer angehängten Nummer angelegt. Auch hier gehen keine Eingaben verloren.
Der Link zum Pattern_Configurator wird erst Angelegt, wenn dieser das erste Mal gestartet wurde. Das macht man am besten über das „Optionen“ Menü des Prog_Generators:
Bild


@Ulrich:
Ich habe eine 64 Bit Windows, aber kein 64 Bit Office ;-(
Zum testen müsste ich mir aber alle möglichen (und unmöglichen) Kombinationen zulegen. Wenn ich alles auf 64 Bit teste, dann funktioniert es wieder unter 32 Bit nicht. Oder es gibt einen Kollegen der noch Office 2010 benutzt. Dann gibt es Leute mit einer anderen Spracheinstellung oder anderen Dezimaltrennzeichen. Es gibt unendlich viele Kombinationen ;-(
Trotzdem ärgert es mich, wenn ich immer wieder den gleichen Fehler mache und das „PrtSafe“ an einer Stelle vergesse. In welchem Modul ist mir den das wieder passiert? Aus Deinem Bild kann ich das nicht so einfach rekonstruieren.


Habe ich alle Fragen beantwortet?

Vielen Dank für das Lob an alle

Hardi
Haltet Euch unbedingt von diesen Seiten fern:
viewtopic.php?f=7&t=165060&sd=a&start=0
https://wiki.mobaledlib.de/
sonst wird Eure Anlage niemals fertig…

Benutzeravatar

ThKaS
CityNightLine (CNL)
Beiträge: 1507
Registriert: Do 28. Apr 2005, 08:37
Wohnort: München
Kontaktdaten:
Jamaika

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1009

Beitrag von ThKaS »

ThKaS hat geschrieben:
Fr 29. Nov 2019, 18:50
Moin moin,

für die pdf-Begeisterten: Ich habe die Ergänzung bis Beitrag 990 online gestellt.

Beitrag zur pdf-Dokumentation
lieben Gruss von südlich des Weisswurst-Äquators
Thomas

guckst: www.thkas-moba.de ‹(•¿•)› www.mucis.de

Bild

Mä-K-Gleis, Tams MC, Multi-Kulti Decoder, WDP


WolfHo
RegionalExpress (RE)
Beiträge: 68
Registriert: Do 10. Okt 2019, 18:41
Nenngröße: N
Stromart: digital
Steuerung: Intellibox, Railware, Arduino
Gleise: Arnold
Wohnort: Dietzenbach
Alter: 74
Deutschland

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1010

Beitrag von WolfHo »

Hallo Hardi,

habe jetzt auch Pattern V. 0.91, die 0.90 war wohl noch aus der Lib 1.0.0 von gestern.

Das ist ja Wahnsinn, was im Prog Generator jetzt alles an tollen Effekten dazu gekommen ist, die wir uns so sehnlich gewünscht hatten.

Herzlichen Dank für alles.

Gruß Wolf
SpurN Arnold Gleis 60 m, Anlage 2,50x0,70 m, Sbhf 16 Gl., Bhf 7 Gl., BW mit Drehscheibe, 50 Loks, Epoche 3, Fahren IBox I Com2, Booster LDT DB-4; Schalten S-DEC-4, WDECN-TN; Melden HSI-88 (Com3), RM-GB-8(-N). Steuerung Railware 7.34, PC: Core i5 750 , 8 GB RAM, Win10 pro 64Bit


Misha
Regionalbahn (RB)
Beiträge: 29
Registriert: So 22. Dez 2019, 07:26
Nenngröße: H0
Stromart: digital
Steuerung: Koploper
Gleise: Marklin K-Rail
Wohnort: Utrecht / Nederland
Alter: 62
Niederlande

Re: Die neue Version 1.0.1 der MobaLedLib ist endlich verfügbar

#1011

Beitrag von Misha »

Hardi hat geschrieben:
Sa 18. Jan 2020, 12:11

@Ulrich:
Ich habe eine 64 Bit Windows, aber kein 64 Bit Office ;-(
Zum testen müsste ich mir aber alle möglichen (und unmöglichen) Kombinationen zulegen. Wenn ich alles auf 64 Bit teste, dann funktioniert es wieder unter 32 Bit nicht. Oder es gibt einen Kollegen der noch Office 2010 benutzt. Dann gibt es Leute mit einer anderen Spracheinstellung oder anderen Dezimaltrennzeichen. Es gibt unendlich viele Kombinationen ;-(
Trotzdem ärgert es mich, wenn ich immer wieder den gleichen Fehler mache und das „PrtSafe“ an einer Stelle vergesse. In welchem Modul ist mir den das wieder passiert? Aus Deinem Bild kann ich das nicht so einfach rekonstruieren.

Hardi
Hallo Hardi

Hier geht es schief. Siehe das Bild. Hoffentlich hast du genug davon.

Grüße Misha.
Bild


Railcar
InterRegio (IR)
Beiträge: 187
Registriert: Do 15. Nov 2018, 09:41
Alter: 67

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1012

Beitrag von Railcar »

Hi Hardi und @ all die es betrifft:

In dem betreffenden Modul - M57_modCOMM (das in dem der Fehler auftritt), einfach alle

declare Function durch declare PTRSafe Function ersetzen.

Dann sollte es auch im 64 Bit Office klappen.

Der Fehler tritt nur im Pattern Configurator auf.

Ulrich


Railcar
InterRegio (IR)
Beiträge: 187
Registriert: Do 15. Nov 2018, 09:41
Alter: 67

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1013

Beitrag von Railcar »

Hi Hardi,

in der Funktion im Prog. Generator "Def_Neon_Mischa" wird die LED nicht hochgezählt sondern steht fest auf 1.
Lade ich Set_def_Neon wird zwar die LED hochgezählt, aber LEDs steht auf 0.
Irgendwo ist bei beiden Funktionen der Wurm drin.

Bild

Set_tv bringt die gleichen / selben Fehler

Bild


Ulrich

Edit: Bild hinzugefügt

Edit: Bild mit neuem Fehler hinzugefügt.

Edit: Lösche Zeilen - löscht nicht nur die markierten Zeilen sondern alle bis zum Ende.
Neuer Button - lösche alles ab hier bis zum Ende ??


Misha
Regionalbahn (RB)
Beiträge: 29
Registriert: So 22. Dez 2019, 07:26
Nenngröße: H0
Stromart: digital
Steuerung: Koploper
Gleise: Marklin K-Rail
Wohnort: Utrecht / Nederland
Alter: 62
Niederlande

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1014

Beitrag von Misha »

Hallo Hardi

Ich war mit der Kirmis-Präsentation beschäftigt. An sich scheint es nur mit dem letzten Befehl (# LocInCh + 4) nicht zu funktionieren, es geht immer schief. Anfangs startet die Serie gut, aber nach dem ersten Durchgang geht die letzte nicht aus und die andere Serie beginnt, sie zu durchlaufen.

PM_NORMAL, PM_SEQUENZ_W_RESTART, PM_SEQUENZ_W_ABORT, PM_SEQUENZ_NO_RESTART, PM_SEQUENZ_STOP, PF_NO_SWITCH_OFF.

Ich habe alle erdenklichen Parameter ausprobiert, kann aber den letzten Satz nicht stoppen.
Das Ändern der Reihenfolge spielt ebenfalls keine Rolle. Letzteres schaltet nicht immer ab.
Kann das ein Bug sein?

Hiermit mein Prog Gen Bild und meine letzte Serie von Patt-Gen:

Bild


Bild

Im Video können Sie sehen, was los ist.

Ganz links im Video mein Schweißlicht und ganz rechts mir 5 Neonröhren, bei denen das Medium defekt ist.
In der Mitte ein Versuchsaufbau einer möglichen Kirmis-Präsentation.

[vimeo]https://vimeo.com/385683025/f97b41ee88[/vimeo]

Derzeit arbeite ich immer noch mit den 'alten' Versionen des Prog-Gen und des Patt-Gen, da im Patt-Gen immer noch eine 64-Bit-Fehlermeldung angezeigt wird.

Grüße Misha.

Benutzeravatar

Threadersteller
Hardi
InterCity (IC)
Beiträge: 672
Registriert: Mo 28. Dez 2015, 13:07
Nenngröße: H0
Stromart: digital
Steuerung: MS2 + IR, Eigenbau
Gleise: Märklin C-Gleis
Wohnort: Mainz
Alter: 56
Deutschland

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1015

Beitrag von Hardi »

Hallo Ulrich,

Die Set_... Zeilen setzen nur die Parameter für die folgenden Befehle. Darum ist der Eintrag in „LEDs“ 0 . Diese Befehle wirken sich nicht auf den LED Zähler aus.
Mit dem „Set_Def_Neon“ Befehl wird das Verhalten der defekten Neonlampen konfiguriert. Erst wenn in einem „House()“ Makro der Parameter „NEON_DEF…“ verwendet wird, dann werden diese Änderungen wirksam.
Der „Set_Def_Neon“ kann vor jedem „House()“ Befehl verwendet werden wenn man ein unterschiedlichen Fehler simulieren will.

Bei dem „Set_TV..“ ist es genauso. Dieser Befehl wirkt sich aber auf alle TV-Geräte aus auf denen der entsprechende Kanal läuft. Es gibt in „unserer Welt“ nur zwei TV-Programme und fragt nicht nach einem weiteren Programm. Ich verweigere seit mindestens 5 Jahren diese Flimmerkisten und werde das nicht auf der Anlage unterstützen.

Der „Def_Neon_Mischa()“ Befehl ist unabhängig von dem „Set_Def_Neon“ Kommando. Das ist verwirrend, aber ich wollte beide Methoden zur Verfügung stellen.

=> Die Befehle verhalten sich richtig. Die Start LedNr wird richtig hoch gezählt. Nur die Doku ist mal wieder Besch…
Hoffentlich habe ich das halbwegs erklären können.


„Lösche Zeilen“ Knopf löscht alle Zeilen
Das ist ein Bug den ich noch nicht ganz verstanden habe. Die Zeilen werden zum Glück wirklich gelöscht, sondern nur ausgeblendet. Das liegt an dem Autofilter von Excel. In der Spaltenüberschrift ist ein graues Kästchen mit einem Dreieck. Wenn man darauf klickt öffnet sich der Filter Dialog:
Bild
Hier kann es vorkommen, dass das Häkchen bei „(Leere)“ verschwunden ist. Wenn das der Fall ist werden alle Zeilen unsichtbar in denen nichts in der entsprechenden Spalte („Filter“) steht. Ich weiß nicht wann das auftritt. Eben ist es bei mir auch passiert als ich eine Zeile gelöscht habe. Jetzt tritt es nicht mehr auf.
=> Momentan muss man das Häkchen „von Hand“ wieder setzen.

Über den Filter kann man gezielt Zeilen ein und ausblenden. Momentan stehen hier die ganzen Beispiele. Man kann die Filter aber auch für eigene Bereiche verwenden. Dann kann man schnell mal einen ganzen Block (Bahnhof, Stadt, …) ausblenden.


Den Fehler mit dem PTRSave werde ich hoffentlich in Zukunft überlisten indem ich mir einen Eintrag in meine „Todo Bevor Release“ Liste mache. Vielleicht hilft es.

Vielen Dank Für die Meldungen.
Der Dank gilt natürlich auch an Misha.


Hardi
Haltet Euch unbedingt von diesen Seiten fern:
viewtopic.php?f=7&t=165060&sd=a&start=0
https://wiki.mobaledlib.de/
sonst wird Eure Anlage niemals fertig…


Railcar
InterRegio (IR)
Beiträge: 187
Registriert: Do 15. Nov 2018, 09:41
Alter: 67

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1016

Beitrag von Railcar »

Hi Hardi,
irgendwie scheinen die neuen pop-up Fenster nicht die richtigen Y Koordinaten zu haben.
Sie beginnen ausserhalb des Fensters und lassen sich auch nicht bewegen.

Bild

Ulrich


Railcar
InterRegio (IR)
Beiträge: 187
Registriert: Do 15. Nov 2018, 09:41
Alter: 67

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1017

Beitrag von Railcar »

Hi Hardi,

mit den Neon und TV Einstellungen hattest du Recht, Und Neon_Mischa läuft alleine.

Frage: Woran erkennt man den guten Programmierer?
Antwort: An der Dokumentation, die hinkt der Programmentwicklung nämlich immer hinterher. Anders gesagt - es gibt keine.

No offense - aber unsere Programmierer konnten gar keine Dok schreiben, insofern sieht das bei dir schon alles sehr gut aus. Aber es sind eben die Kleinigkeiten, s.o. über die man stolpert.

Einen habe ich noch.
Als Beispiel: Ich habe einen 2812 Streifen in dem 5 LEDs programmiert sind. Wenn ich nun LED 2 und 4 nicht mehr nutzen möchte, muss ich sie als Reserve_LED programmieren, da sie sonst den vorherigen Wert (Farbe) behalten und nur Reserve_LED anscheinend den internen Befehlsspeicher des 2812 löscht.
Gibt es sonst noch eine Möglichkeit nicht genutzte LEDs zu deaktivieren - sieht halt blöd aus wenn da eine LED so vor sich hinglimmt als ob sie kaputt ist.

Die Sache mit dem Lösche Zeilen Button scheint ein Zufallsgenerator zu sein. Mal gehts nicht, mal gehts. Wenn man weiß wie man es beheben kann stört es nicht.

Ulrich


WolfHo
RegionalExpress (RE)
Beiträge: 68
Registriert: Do 10. Okt 2019, 18:41
Nenngröße: N
Stromart: digital
Steuerung: Intellibox, Railware, Arduino
Gleise: Arnold
Wohnort: Dietzenbach
Alter: 74
Deutschland

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1018

Beitrag von WolfHo »

Hardi hat geschrieben:
Sa 18. Jan 2020, 18:08

Es gibt in „unserer Welt“ nur zwei TV-Programme und fragt nicht nach einem weiteren Programm. Ich verweigere seit mindestens 5 Jahren diese Flimmerkisten und werde das nicht auf der Anlage unterstützen.
Traumhaft, Hardi, wenn auch ich in 1:1 die Flimmerkiste verringern könnte. Ich wäre froh, bloß würde dann der Haussegen leiden. Aber auf der Anlage finde ich diese Effekte doch sehr wichtig gegenüber einer statischen Fensterausleuchtung. Die Preiser sollten deswegen dort doch besser ebenfalls nur "Normalbürger" sein.

Gruß Wolf
SpurN Arnold Gleis 60 m, Anlage 2,50x0,70 m, Sbhf 16 Gl., Bhf 7 Gl., BW mit Drehscheibe, 50 Loks, Epoche 3, Fahren IBox I Com2, Booster LDT DB-4; Schalten S-DEC-4, WDECN-TN; Melden HSI-88 (Com3), RM-GB-8(-N). Steuerung Railware 7.34, PC: Core i5 750 , 8 GB RAM, Win10 pro 64Bit


WolfHo
RegionalExpress (RE)
Beiträge: 68
Registriert: Do 10. Okt 2019, 18:41
Nenngröße: N
Stromart: digital
Steuerung: Intellibox, Railware, Arduino
Gleise: Arnold
Wohnort: Dietzenbach
Alter: 74
Deutschland

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1019

Beitrag von WolfHo »

Hallo Ulrich,

ich hatte auch mal so etwas ähnliches mit den LEDs, da hat es dann geholfen, den USB-Stecker oder die sonstige Stromversorgung für einige Sekunden abzuziehen. Danach lief es wieder gut, der Nano hat wohl die alten Programme erst dann vergessen.

Gruß Wolf
SpurN Arnold Gleis 60 m, Anlage 2,50x0,70 m, Sbhf 16 Gl., Bhf 7 Gl., BW mit Drehscheibe, 50 Loks, Epoche 3, Fahren IBox I Com2, Booster LDT DB-4; Schalten S-DEC-4, WDECN-TN; Melden HSI-88 (Com3), RM-GB-8(-N). Steuerung Railware 7.34, PC: Core i5 750 , 8 GB RAM, Win10 pro 64Bit

Benutzeravatar

Threadersteller
Hardi
InterCity (IC)
Beiträge: 672
Registriert: Mo 28. Dez 2015, 13:07
Nenngröße: H0
Stromart: digital
Steuerung: MS2 + IR, Eigenbau
Gleise: Märklin C-Gleis
Wohnort: Mainz
Alter: 56
Deutschland

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1020

Beitrag von Hardi »

Hallo Ulrich,
Railcar hat geschrieben:
Sa 18. Jan 2020, 18:43
irgendwie scheinen die neuen pop-up Fenster nicht die richtigen Y Koordinaten zu haben.
Sie beginnen ausserhalb des Fensters und lassen sich auch nicht bewegen.
Vielen Dank, dass Du Dich so intensiv mit dem Programm beschäftigst.

Ich habe die Anzahl der Parameter in dem Dialog von 7 auf 14 erhöht. Dadurch wird der Dialog zu hoch für einen kleinen Bildschirm. Es werden zwar in dem Fall nicht alle Parameter angezeigt, aber dummerweise ist die obere Position doch außerhalb des Bildschirms. Ich habe das hoffentlich verbessert.
Wenn so etwas passiert, dann kann man mit ALT+Leertaste gefolgt von v und einer Pfeiltaste den Dialog oder das Fenster mit der Maus bewegen auch wenn man nicht an die Titelleiste kommt. Das funktioniert bei vielen Windows Fenstern. Bei dem fraglichen Dialog geht das auch.
Railcar hat geschrieben:
Sa 18. Jan 2020, 19:11
Frage: Woran erkennt man den guten Programmierer?
Antwort: An der Dokumentation, die hinkt der Programmentwicklung nämlich immer hinterher. Anders gesagt - es gibt keine.

No offense - aber unsere Programmierer konnten gar keine Dok schreiben, insofern sieht das bei dir schon alles sehr gut aus. Aber es sind eben die Kleinigkeiten, s.o. über die man stolpert.
Wie soll ich die beiden Aussagen werten?
  1. Ein guter Programmiere kann keine Doku schreiben
  2. Meine Doku sieht schon ganz gut aus
Egal, ich fasse es als Kompliment auf… Danke
Railcar hat geschrieben:
Sa 18. Jan 2020, 19:11
Als Beispiel: Ich habe einen 2812 Streifen in dem 5 LEDs programmiert sind. Wenn ich nun LED 2 und 4 nicht mehr nutzen möchte, muss ich sie als Reserve_LED programmieren, da sie sonst den vorherigen Wert (Farbe) behalten und nur Reserve_LED anscheinend den internen Befehlsspeicher des 2812 löscht.
Gibt es sonst noch eine Möglichkeit nicht genutzte LEDs zu deaktivieren - sieht halt blöd aus wenn da eine LED so vor sich hinglimmt als ob sie kaputt ist.
Dieser Effekt tritt nur während der Programmierung auf. Wenn Der Strom abgeschaltet ist „vergessen“ die WS2812 die alten Werte. Aber mich stört es auch immer. Ich füge darum oft am Ende einen „Reserve LEDs(10)“ Befehl ein. Das habe ich nicht fest in der Bibliothek eingebaut, weil die Anzahl bei jedem anders sein kann und natürlich, weil der Befehl Rechenzeit kostet. Die zusätzlichen LEDs müssen ja alle 20 ms gesagt bekommen, dass sie aus seien sollen. Das Ausstecken der LEDs wie Wolf das gerade beschrieben hat ist vermutlich die beste Lösung.

@Wolf: Es ist nicht der Nano der sich die Daten merkt, sondern die WS2812 LEDs. Wenn sie keine neuen Daten bekommen behalten sie die alten Helligkeiten so lange bei bis ein neuer Befehl kommt oder man ihnen den Saft abdreht.



Ich habe die beiden Excel Programme verbessert und auf GitHub hochgeladen aber keine neue Version der Bibliothek generiert.
=> Ihr müsst die beiden Dateien von Hand herunterladen und in das Verzeichnis „…\Arduino\MobaLedLib_1.0.1\“ kopieren oder wie in den dem Beitrag #1008 geschrieben habe die ganze ZIP Datei herunterladen und als Zip installieren.

Die 64 Bit Problematik habe ich geändert, kann es aber nicht testen. Darum bin ich auf Eure Hilfe angewiesen. Ihr könnt das Ganze auch ohne Charlieplexing Modul testen indem Ihr einfach eine RGB LED anschließt. Beim Hochladen der Daten gibt es ja leider kein Feedback. Öffnet dazu das die Seite „Viessman.4751“ ganz am Ende und klickt auf den „Zum Modul schicken“ Knopf. Nach der Auswahl der LED sollte diese dann eine Zeit lang flackern bis 100% der Daten übertragen wurden.
Wenn das nicht klappt, dann währe es schön, wenn sie ein 64 Bit Office Besitzer finden würde mit dem ich das am Telefon und TeamViewer untersuchen könnte.


@Misha: Ich habe Deinen Beitrag gesehen und schaue es mir gleich mal an…

Hardi
Haltet Euch unbedingt von diesen Seiten fern:
viewtopic.php?f=7&t=165060&sd=a&start=0
https://wiki.mobaledlib.de/
sonst wird Eure Anlage niemals fertig…

Benutzeravatar

Threadersteller
Hardi
InterCity (IC)
Beiträge: 672
Registriert: Mo 28. Dez 2015, 13:07
Nenngröße: H0
Stromart: digital
Steuerung: MS2 + IR, Eigenbau
Gleise: Märklin C-Gleis
Wohnort: Mainz
Alter: 56
Deutschland

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1021

Beitrag von Hardi »

Hallo Misha,

ich finde das Video Klasse. Unglaublich was Du alles aus dem Programm heraus holst.
Aber ich kann den Fehler nicht so einfach sehen da ich nicht genau weiß was das Programm machen soll. Schicke mir doch bitte die Konfiguration in Textform, dann kann ich es näher Analysieren. Auf die schnelle denke ich, dass es Hilft wenn Du zu Beginn des ersten Effekts alle LEDs aus machst.

@Alle: Schaut euch das Video von Misha mal an:
[vimeo]https://vimeo.com/385683025/f97b41ee88[/vimeo]

Hardi
Haltet Euch unbedingt von diesen Seiten fern:
viewtopic.php?f=7&t=165060&sd=a&start=0
https://wiki.mobaledlib.de/
sonst wird Eure Anlage niemals fertig…


Misha
Regionalbahn (RB)
Beiträge: 29
Registriert: So 22. Dez 2019, 07:26
Nenngröße: H0
Stromart: digital
Steuerung: Koploper
Gleise: Marklin K-Rail
Wohnort: Utrecht / Nederland
Alter: 62
Niederlande

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1022

Beitrag von Misha »

Hardi hat geschrieben:
Sa 18. Jan 2020, 20:49
Hallo Misha,

ich finde das Video Klasse. Unglaublich was Du alles aus dem Programm heraus holst.
Aber ich kann den Fehler nicht so einfach sehen da ich nicht genau weiß was das Programm machen soll. Schicke mir doch bitte die Konfiguration in Textform, dann kann ich es näher Analysieren. Auf die schnelle denke ich, dass es Hilft wenn Du zu Beginn des ersten Effekts alle LEDs aus machst.

@Alle: Schaut euch das Video von Misha mal an:
[vimeo]https://vimeo.com/385683025/f97b41ee88[/vimeo]

Hardi
Guten Morgen Hardi,

Ich habe vergessen, den Code einzuschließen. Hiermit der Code wie er jetzt ist. Ich hatte schon mehr Optionen darin gemacht. Sie müssen also "LoInch" ganz rechts in der Zeile des Prog-Gen-Blattes auf 7 erhöhen.

Code: Alles auswählen

RandMux(#LocInCh, #LocInCh+7,#InCh,RF_SEQ ,3 Sek, 5 Sek)
PatternT1(#LED,4,#LocInCh+1,24,0,128,0,PM_NORMAL,101,15,0,0,0,0,0,192,3,0,0,0,0,0,240,0,0,0,0,15,0,60,0,0,0,192,3,0,15,0,0,0,240,0,192,3,0,0,0,60,0,240,0,0,0,0,15,0,60,0,0,0,192,3,0,0,0,0,0,240,0,0,0,0,0,0,60,0,0,0,0,240,0,0,0,0,192,3,0,0,0,0,15,0,60,0,0,60,0,240,0,0,240,0,192,3,0,192,3,0,15,0,0,15,0,60,0,0,0,0,240,0,0,0,0,192,3,0,0,0,0)
PatternT1(#LED,4,#LocInCh+2,24,0,128,0,PM_PINGPONG,102,0,195,48,12,195,48,12,192,48,12,195,48,12,3,48,12,195,48,12,195,0,12,195,48,12,195,48,0,195,48,12,195,48,12,192,48,12,195,48,12,3,48,12,195,48,12,195,0)
PatternT1(#LED,8,#LocInCh+3,24,0,128,0,PM_NORMAL,106,0,0,0,96,196,8,0,0,0,0,0,48,2,0,128,17,0,0,0,24,1,0,0,0,0,35,0,140,0,0,0,0,0,0,0,70,0,24,1,0,0,0,0,35,0,0,0,48,2,0,128,17,0,0,0,0,0,96,196,8,0,0,0)
PatternT1(#LED,4,#LocInCh+4,24,0,128,0,PM_PINGPONG,103,48,0,0,0,0,0,0,12,0,0,0,0,0,0,3,0,0,0,0,0,192,0,0,0,0,0,0,48,0,0,0,0,0,0,12,0,0,0,0,0,0,3,0,0,0,0,0,192)
PatternT1(#LED,4,#LocInCh+5,24,0,128,0,PM_NORMAL,105,12,0,0,0,0,48,192,3,0,0,240,0,0,48,0,192,0,0,0,0,252,63,0,0,0,48,0,192,0,0,192,3,0,0,240,0,12,0,0,0,0,48)
APatternT1(#LED,8,#LocInCh+6,24,0,128,0,PM_PINGPONG,107,7,112,252,0,126,28,255,255,227,56,14,224,248,1,252,56,254,255,63,112,28,192,241,3,248,113,252,192,127,224,56,128,227,7,240,227,199,129,255,192,113,0,199,15,224,248,143,3,255,129,227,0,142,31,199,241,31,7,254,3,199,1,28,255,143,227,63,14,252,7,142,3,248,255,31,199,127,28,248,15,28,199,241,255,63,142,255,56,240,31,192,143,227,255,127,28,255,113,224,63,128,31,199,255,255,56,254,227,56,126,0,63,142,255,255,113,252,7,112,252,0,126,28,255,255,227)
PatternT1(#LED,4,#LocInCh+7,24,0,128,0,PM_NORMAL,104,0,0,0,0,0,0,195,48,12,195,48,12,0,0,0,0,0,0)
Ich bin gespannt, was los ist.

Grüße Misha.


Railcar
InterRegio (IR)
Beiträge: 187
Registriert: Do 15. Nov 2018, 09:41
Alter: 67

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1023

Beitrag von Railcar »

Hi Hardi,

Fehler im LED Test Programm 1.26?

Es lassen sich max. 4 LEDs (0-3) ansprechen.
Bei LED Adresse 3 Anzahl 1 blinkt die 3. LED - bei Anzahl 2 sollten die 3. und die 4 blinken , tun sie aber nicht

LEDs ab Adresse 4 werden überhaupt nicht mehr angesprochen.

Und ja - meine LEDS sind alle heile.

Könnte das mal jemand überprüfen.

Ulrich


hlinke
S-Bahn (S)
Beiträge: 23
Registriert: Di 31. Okt 2006, 22:02
Wohnort: Trier

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1024

Beitrag von hlinke »

Hallo Ulirch,

kannst Du in den Einstellungen überrüfen, welcher Wert für die maximale Anzahl der LED angegeben ist.

Der ARDUINO überträgt jetzt beim Verbindungsaufbau die Anzahl der eingerichteten LEDs.

Dies ist die Anzahl der LED die Du in dem ARDUINO mit dem ProgGen Programm eingerichtet hast.

Wenn Du also nur 4 LEDs eingerichtet hast, geht das Programm davon aus, dass nur 4 LEDs angeschlossen sind.

Ich bin darauf auch am Anfang mal reingefallen.

Mit einem Housbefehl, der alle LED, die angeschlossen sind, beinhaltet, kannst Du dem ARDUINO und dem Farbtestprogramm mittteilen, wieviele LED vorhanden sind.

Ich hoffe, das hilft Dir weiter.

Viele Grüsse
Harold


Railcar
InterRegio (IR)
Beiträge: 187
Registriert: Do 15. Nov 2018, 09:41
Alter: 67

Re: MobaLedLib: Beginn einer neuen Ära mit Windows Konfigurationstool. Programmieren war Gestern ... Neu: Ver.: 1.0

#1025

Beitrag von Railcar »

HI Harold,

da hatte ich auch schon dran gedacht, aber die maximale LED Anzahl steht auf 256.
Da liegt es nicht dran.

Ulrich

Edit:

Wenn ich alle LEDs mit dem Arduino aktiviere, bevor ich das LED Testprogramm nutze klappt es, aber soll das so sein?
Ich dachte ich kann über die LED Nummer und Anzahl genau die LED bestimmen und diese dann einstellen welche Farbe sie haben soll. So muss ich erst alle LEDs aktivieren, und wenn es RESERVE ist, um die LED genau zu bestimmen. Irgendwie umständlich?!
Zuletzt geändert von Railcar am So 19. Jan 2020, 10:49, insgesamt 1-mal geändert.

Antworten

Zurück zu „Software und Hardware“