Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

Bereich für alle Themen rund um Modellbahn-Software, sowie der nötigen Hardware (PCs, Bildschirme, etc.).

eiserneryuppi
S-Bahn (S)
Beiträge: 15
Registriert: Mo 30. Jul 2018, 11:32
Nenngröße: H0
Stromart: DC
Wohnort: Cottbus
Nordkorea

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#401

Beitrag von eiserneryuppi » Sa 8. Sep 2018, 12:12

Vielen Dank für die schnelle Rückmeldung.

Mit den Logiktabellen war ich etwas verwirrt, da es öfter mal hier im Thread mal hieß das die Logiktabelle vom Datenblatt abweicht.
Das die Spannung am Ausgang anliegt habe ich auch gemessen. Hier hab ich überlegt ob ich noch ein Relais zwischenschalte und der Arduino dann die Spannung erst freigibt wenn auch das Digitalsignal anliegt. Ist ja nen Witz. Das ist aber eine andere Geschichte.

Mein Aufbau ist auf Lochraster.
Der Grund warum ich die Eingänge gemessen habe ist das hier öfter berichtet wurde das die TLEs defekt sind oder nicht wie gewünscht funktionieren.
Und auch schon den ein oder anderen Arduino mit in den Tod gerissen haben. Das wollte ich mir ersparen.

Die mir online verfügbaren Pläne von PGs Website sind immer mit der Beschiftung TLE 5205. Im anscheinend "veralteten" Boosterlayout sind Dioden zumindest beim DCC. http://pgahtow.de/wiki/index.php?title= ... ooster.png
Könnte ich dann also auch einfach Dioden an GO/STOP2 und DCC zwischenlöten oder verträgt sich das nicht mit dem Signal?

Könnte jemand von euch vielleicht messen ob an den INs vom TLE Strom anliegt ohne Mega?


black5

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#402

Beitrag von black5 » Sa 8. Sep 2018, 12:22

Hi, warum willst du da Dioden einsetzen, das hat hier noch niemand geMacht, und ist auch nicht nötig....
Und wenn, dann extrem schnelle Schaltdioden um das Signal nicht zu verzerren.

Die Boosterschaltung auf die du dich beziehst ist "veraltet" und wird nicht mehr genutzt, da dort kein Railcom unterstützt wird.
In der Platine kommt die TLE Booster 3R Schaltung zum Einsatz.

Wie Weit ist denn deine Verbindung Mega und Wlan Modul - hast du dann schon Erfolg?

Ulrich

Edit: TLE5205-x und TLE5206-x sind baugleich, nur der 5206 ist für einen höheren Strom ausgelegt. Nachteil - er ist von Infineon abgekündigt und keiner weiß wie lange er noch verfügbar ist, Lt. Infineon soll er nicht mehr für Neuentwicklunbgen genutzt werden.


eiserneryuppi
S-Bahn (S)
Beiträge: 15
Registriert: Mo 30. Jul 2018, 11:32
Nenngröße: H0
Stromart: DC
Wohnort: Cottbus
Nordkorea

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#403

Beitrag von eiserneryuppi » Sa 8. Sep 2018, 15:15

Die Idee mit den Dioden kam da anscheinend 5V und 3V aus dem Eingang des TLE kommen. Vielleicht bin ich da physikalisch/elektrotechnisch nicht so bewandert aber ich hab etwas Bammel das es mir den Mega himmelt. Deswegen auch die Bitte nach einer Messung bei euch. Vielleicht is das ja ganz normal. Im Netz hab ich dazu nur gefunden das er dann wahrscheinlich defekt ist.

(Deswegen ist der Mega noch nicht angeschlossen und auch noch nicht programmiert, genauso das ESP-Modul.)


black5

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#404

Beitrag von black5 » Sa 8. Sep 2018, 15:50

Probier doch einfach mal, den Mega und den ESP mit dem Sketch zu flashen, dann solltest du zumindest im Serialmonitor was lesen können. Und wenn du ein Smartphone nutzt solltest du z
eine Verbindung herstellen können und mit der z21 App siehst du z.b. am flackern der blauen Led ob sende und Empfangswege in Ordnung sind
Ulrich


andreas21
InterRegio (IR)
Beiträge: 180
Registriert: Fr 6. Jul 2018, 05:50
Nenngröße: TT
Stromart: digital
Steuerung: z21 & selectrix
Gleise: Modellgleis Tillig
Wohnort: Potsdam
Alter: 54
Deutschland

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#405

Beitrag von andreas21 » Sa 8. Sep 2018, 19:30

Hallo eiserneryuppi,

ich hatte schon einige Platinen zur Reparatur und der Austausch des TLE5205 war die Lösung.
Ein Arduino war auf diesen Platinen nicht defekt.
Auf den Platinen hatte ich vor dem Austausch des TLE5205 die Spannungen gemessen und auf einem Steueranschluss war die Fahrspannung.
Bei einem TLE5206 sind an PIN EN, IN1 und IN2 +5V ohne Arduino.

Es ist besser den TLE5206-2S zu verwenden. Auch in meinen Zeichnungen kann noch TLE5205 stehen, dieses Bauteil ist in Eagle verfügbar.
Ich habe jetzt 20 Zentralen mit dem TLE5206-2S aufgebaut, alle arbeiten ohne Fehler.
Du solltest aber einen 10kohm Widerstand in die Currend Sence Verbindung zwischen den TLE und den Adruino schalten.
viewtopic.php?p=1850631#p1850631
Der Pin 4 des TLE muss mit GND über den Widerstand 0,33 ohm verbunden sein bevor die Fahrspannung angeschlossen wird.
Fehlt diese Verbindung bei einem Test gelangt die Fahrspannung zum Arduino.

Viele Grüße
Andreas
Zuletzt geändert von andreas21 am Fr 2. Nov 2018, 22:19, insgesamt 1-mal geändert.


vikr
InterRegioExpress (IRE)
Beiträge: 289
Registriert: So 23. Okt 2011, 19:05
Nenngröße: H0
Stromart: AC
Steuerung: PC
Gleise: MMärklin C
Alter: 65

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#406

Beitrag von vikr » So 9. Sep 2018, 07:46

Hallo Ulrich,
black5 hat geschrieben:
Sa 8. Sep 2018, 12:22
Edit: TLE5205-x und TLE5206-x sind baugleich, nur der 5206 ist für einen höheren Strom ausgelegt. Nachteil - er ist von Infineon abgekündigt und keiner weiß wie lange er noch verfügbar ist, Lt. Infineon soll er nicht mehr für Neuentwicklunbgen genutzt werden.
Es macht daher durchaus Sinn die Platine auch ohne TLE zu verwenden, d.h. ohne internen Leistungsbaustein und ausschließlich mit Boostern am CDE-Ausgang. Natürlich kann man dann nicht auf die (elegante, TLE-typische aber ansonsten eher wenig verbreitete) interne Logik des TLE setzen. Die Kurzschlusserkennung erfolgt dann über CDE, sonst ändert sich m.E. nichts.

MfG

vik


eiserneryuppi
S-Bahn (S)
Beiträge: 15
Registriert: Mo 30. Jul 2018, 11:32
Nenngröße: H0
Stromart: DC
Wohnort: Cottbus
Nordkorea

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#407

Beitrag von eiserneryuppi » So 9. Sep 2018, 16:32

Vielen Dank Andreas.

Komisch das ich 5V, 3V und 0,0irgendwasV auf EN habe... Was solls.
Also kann ich wohl bedenkenlos den Arduino an meine jetzige Konstruktion anschließen.
Den 10k Widerstand für current_sense habe ich bereits zuvor angefügt sogar den Kondensator hatte ich noch in der Bastelkiste. Auch der 0,33Ohm war bereits verbaut. Den TLE 5205-2 hatte ich damals bestellt wie bereits erwähnt aufgrund der Angaben in den Zeichnungen.
Komisch das im Datenblatt der 5205-2 und der 5205-2S für mich nur als baulicher Unterschied zu verstehen ist.
Da ist es gut auf eure Erfahrungen zurückgreifen zu können.
Werde das jetzt erstmal damit testen.
Ist der Temperatur-Sensor TEMP zum Betrieb zwingend nötig, oder reicht das wenn man den später nachrüstet :) ?

@vikr/Ulrich
Wo finde ich einen Bauplan für einen günstigen Booster? :)
Zuletzt geändert von eiserneryuppi am So 9. Sep 2018, 17:35, insgesamt 1-mal geändert.


murdok1980
InterRegio (IR)
Beiträge: 176
Registriert: So 11. Feb 2018, 23:03
Nenngröße: G
Stromart: digital
Steuerung: RC, Eigenbau, Z21 Nachbau
Gleise: Piko
Wohnort: Leppersdorf (Radeberg)
Alter: 38
Deutschland

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#408

Beitrag von murdok1980 » So 9. Sep 2018, 16:50

Hallo
Das hier ist ein einfacher Booster.
https://wiki.rocrail.net/doku.php?id=or ... 857a81880
Den hat Andreas auch schon nachgebaut und eine eigenes Layout erstellt. Der Booster ist einstellbar und geht bis 10A.
Grüße
Andre


black5

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#409

Beitrag von black5 » So 9. Sep 2018, 17:12

Hi eiserneryuppi,

für den reinen Betrieb brauchst du weder Temp noch V_Rail (Trackspannung) noch Current_sence.

Die Trackspannung die du einstellst hat nichts mit der tatsächlichen Trackspannung zu tun, du änderst hier nur die Anzeige für die Spannung, entweder in der Z21 App oder z.B. in RocRail. Du hast jedoch keine Möglichkeit die Spannung direkt mit der App zu ändern, so wie es die Original Z21 tut, das geht nur mit einem regelbaren Netzteil.
Ebenso die Temperatur, hier kannst du einstellen was du willst, oder die Anzeige weg lassen.

Ob die Anzeige von Current_Sence, hier rollen sich mir die Fussnägel hoch, das hat nichts mit Sinn zu tun sondern sollte Sense (bemerken, fühlen, abtasten) heissen, sinnvoll ist, sei dahin gestellt. Interessant ist es vielleicht hier einmal einen Wert zu haben wieviel Strom beim Betrieb fließt, aber unbedingt nötig zum Betrieb sind diese 3 (TEMP, CURRENT_SENCE, V_RAIL) nicht, die Schaltung funktioniert auch einwandfrei ohne diese.

TLE-5205/TLE5206 und TLE-5205S/TLE5206S unterscheiden sich in den Anschlüssen. Beide kommen im TO-220 Gehäuse, die Anschlussbeine sind beim 520X allerdings geschränkt, und versetzt angeordnet.Bild
Beim 520xS liegen alle 7 Beinchen in einer Reihe nebeneinanderBild
Die anderen beiden Typen - 2G und 2GP - sind SMS Bausteine und auf dieser Platine ohne Anpassung nicht zu verwenden.

Wie willst du denn steuern, mit Loconet oder über die APP?

Ulrich


eiserneryuppi
S-Bahn (S)
Beiträge: 15
Registriert: Mo 30. Jul 2018, 11:32
Nenngröße: H0
Stromart: DC
Wohnort: Cottbus
Nordkorea

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#410

Beitrag von eiserneryuppi » So 9. Sep 2018, 17:53

ups, da hab ich einfach blöde nachgequatscht. SENCE findet sich hier überall. Eigentlich sollte ichs besser wissen.

Zum CVs auslesen braucht mans (sense) aber, oder? Stand hier irgendwo im Thread.

Wie du es erklärst hätte ichs auch verstanden. Mir erklären sich dann die Qualitätsunterschiede nicht. Bin erstmal glücklich mit dem was ich habe.

Habe es vor mit der App zu testen, besitze kein anderes Equipment, und später Rückmeldung per Loconet. Eventuell bau ich in Zukunft auch noch nen Loconetregler. Eins nach dem Anderen.

Suche nach einem Booster auf Arduinobasis. Bin noch nicht so firm mit den ganzen Digital Standarts und Abkürzungen und muss mich dazu erstmal noch ein bisschen bilden bevor ich daherrede. Das bis jetzt geplante Projekt bedarf noch keinem Booster.


black5

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#411

Beitrag von black5 » So 9. Sep 2018, 18:46

Mach dir keinen Stress,
du hast Recht, um die CVs auszulesen brauchst du Current_Sense. Aber da hier in der Z21pg das Timing irgendwie nicht 100% passt, nehme ich zum schreiben und lesen lieber DCC++, da habe ich nicht die Probleme die hier schon des öfteren angesprochen worden.

Für den Anfang und zum Einstieg in die Digitalwelt reicht die Z21pg völlig aus, warscheinlich kommen jetzt wieder Kommentare wie: kauf dies, kauf das für den Anfang etc, und schon bist du viel Geld los - lieber einfach anfangen und dann ausbauen.

Die App läuft mit der Z21pg gut zusammen, wenn du nicht unbedingt einen Regler selber bauen willst, solltest du mal bei ibää schauen, da gibt es oft günstig die Lokmaus 2. Und wie gesagt - für den Anfang reicht es.

Für Steuerung (Weichen und Signale) gibt es einen guten Eigenbaudecoder, wenns dich interessiert lies dich mal hier ein:
viewtopic.php?f=5&t=155926

Den gibts für Loconet und DCC.
Günstiger kannst du nicht einsteigen - in die Arduino Progarmmierung und in die Digitale Moba Welt.

Wenn du es noch einfacher haben willst - hier mal lesen:
https://github.com/DccPlusPlus/BaseStat ... -Plus-Plus

Ulrich


andreas21
InterRegio (IR)
Beiträge: 180
Registriert: Fr 6. Jul 2018, 05:50
Nenngröße: TT
Stromart: digital
Steuerung: z21 & selectrix
Gleise: Modellgleis Tillig
Wohnort: Potsdam
Alter: 54
Deutschland

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#412

Beitrag von andreas21 » So 9. Sep 2018, 21:38

Hallo eiserneryuppi,

mit solchen Werten wird es nicht richtig arbeiten. Der Arduino schaltet die Eingänge zum Steuern nach GND und wenn der EN schon 0V oder GND ist kann dass nicht funktionieren. Ich bin auch der Meinung das der TLE5205 eine andere Logik hat und nur der TLE5206-2S mit dem Sketch auf dem Arduino arbeitet. Ich nutze nur den TLE5206-2S und hatte noch keinen TLE5205 zum testen. Die von mir ausgetauschten 5205 waren nicht mehr zu gebrauchen. Wenn du die Datenblätter der beiden vergleichst (Punkt 1.6), Logic Truth Table, so ist ein Unterschied zu erkennen und das würde auch die Fehler mit dem TLE5205 erklären.
Einen guten Booster "BoosteR-CDE" findest du hier,
http://usuaris.tinet.cat/fmco/railcom_en.html
und wie Andre schon geschrieben hat, mit mehr Leistung,
https://wiki.rocrail.net/doku.php?id=or ... 8857a81880

Viele Grüße
Andreas


vikr
InterRegioExpress (IRE)
Beiträge: 289
Registriert: So 23. Okt 2011, 19:05
Nenngröße: H0
Stromart: AC
Steuerung: PC
Gleise: MMärklin C
Alter: 65

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#413

Beitrag von vikr » Mo 10. Sep 2018, 10:26

Hallo Ulrich,
black5 hat geschrieben:
So 9. Sep 2018, 18:46
Mach dir keinen Stress,
...
Die App läuft mit der Z21pg gut zusammen, wenn du nicht unbedingt einen Regler selber bauen willst, solltest du mal bei ibää schauen, da gibt es oft günstig die Lokmaus 2. Und wie gesagt - für den Anfang reicht es.
...
Wenn du es noch einfacher haben willst - hier mal lesen:
https://github.com/DccPlusPlus/BaseStat ... -Plus-Plus
DCCpp ist wirklich ausgereift und zum DCC-Programmieren (128 Fahrstufen) auf dem Programmiergleis fast perfekt und vom Preis kaum zu unterbieten. Railcom ist dort aber nicht wirklich im Focus und, was aus meiner Sicht noch wichtiger ist:
als Zentrale wird DCCpp außer von Rocrail leider von keinem der gängigen Modellbahnsteuerprogramme unterstützt.

Das heißt für erste Erfahrungen mit Fahren (auch per APP vom Handy), Rückmelden verschiedener Art unter Einbeziehung eines Modellbahnsteuerprogramms ist die Z21pg konkurrenzlos universell ensetzbar ...

MfG

vik


eiserneryuppi
S-Bahn (S)
Beiträge: 15
Registriert: Mo 30. Jul 2018, 11:32
Nenngröße: H0
Stromart: DC
Wohnort: Cottbus
Nordkorea

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#414

Beitrag von eiserneryuppi » Mo 10. Sep 2018, 10:51

@Andreas

Gott mir glüht die Birne zu diesem Problemchen mit dem TLE.
Ja mein Baustein verhält sich dubios aber Folgendes hab ich im Netz recherchieren können:
https://rn-wissen.de/wiki/index.php?tit ... ng#TLE5205
https://www.mikrocontroller.net/topic/435396
http://pgahtow.de/wiki/index.php?title= ... ooster.png
Alles weißt darauf hin das es ein Fehler im Datenblatt des TLE 5205 gibt und er sich genauso verhält wie der 5206 verhält.
Testen kann ich das allerdings nicht. Was ich mir vorstellen könnte ist das sich (chinesische) Nachbauten vielleicht an das Datenblatt gehalten haben?
Das wäre aber nur eine ganz ganz grobe Mutmaßung ohne jegliche stichhaltige Beweise bis auf diese Internetquellen.

@Ullrich

Danke für die Tipps. Das bringt mich gut weiter.


andreas21
InterRegio (IR)
Beiträge: 180
Registriert: Fr 6. Jul 2018, 05:50
Nenngröße: TT
Stromart: digital
Steuerung: z21 & selectrix
Gleise: Modellgleis Tillig
Wohnort: Potsdam
Alter: 54
Deutschland

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#415

Beitrag von andreas21 » Mo 10. Sep 2018, 12:27

Hallo eiserneryuppi,

dein Link zeigt den internen Booster auf der Seite von PG.
Ich nutze nur den TLE Booster3R, ich hatte bei PG gelesen:
Für eine Datenausgabe mit RailCom muss zwingend die Hardware des Booster3R verwendet werden.
Ab der Softwareversion v4.70 ist es möglich Railcom zu aktivieren. Um die für Railcom notwendige Abtastlücke zu erzeugen, muss der interne Booster umgebaut werden.
interner Booster mit Railcom,
http://pgahtow.de/wiki/index.php?title= ... ster3R.png

Viele Grüße
Andreas


Threadersteller
Ingolf
InterRegio (IR)
Beiträge: 156
Registriert: So 30. Aug 2015, 10:15
Nenngröße: H0
Stromart: digital
Steuerung: Z21
Gleise: Piko A
Wohnort: 39629 Bismark
Alter: 63
Deutschland

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#416

Beitrag von Ingolf » Mo 10. Sep 2018, 16:20

Hallo Uwe,

Da ich ja von deiner Micro-Z21 so begeistert war, habe ich die Tage angefangen zu bauen.
Die Platine ist fast fertig, ich warte noch auf den TLE.

Könntest du bitte noch mal über den Sketch schauen ?
Ich habe, wie du beschrieben hast, die von dir veröffentlichten Code-Teile eingefügt. In der .ino ab Zeile 201, für die MCU an das Ende.
Beim Kompilieren werden div. Fehler angezeigt.
Arduino: 1.8.5 (Windows 10), Board: "Arduino Nano, ATmega328P"

In file included from C:\Users\IngoF\Documents\Arduino\Z21_micro\Z21_micro.ino:397:0:

sketch\Z21_LAN.h: In function 'void notifyz21getSystemInfo(uint8_t)':

Z21_LAN.h:477: error: 'Debug' was not declared in this scope

Debug.print("mA: ");

^

exit status 1
'Debug' was not declared in this scope
Der Fehler verweist auf die Z21_LAN.h Zeile 477
Da ich wissen wollte, wie das Kompilieren weiter läuft, habe ich die Zeile 477 einfach auskommentiert.
Der Fehler wiederholte sich, auf die Zeilen 478, 479, 483, 484, 485, 486 verweisend. (Alles Debug.print - Ausgaben)
Ich habe alle diese Zeilen auskommentiert.

Das Kompilieren lief dann weiter bis folgendes kam:
Arduino: 1.8.5 (Windows 10), Board: "Arduino Nano, ATmega328P"

Archiving built core (caching) in: C:\Users\IngoF\AppData\Local\Temp\arduino_cache_814414\core\core_arduino_avr_nano_cpu_atmega328_eebe80b08784ba478cff07c27703f803.a
HardwareSerial0.cpp.o (symbol from plugin): In function `Serial':

(.text+0x0): multiple definition of `__vector_18'

libraries\XpressNetMaster\XpressNetMaster.cpp.o (symbol from plugin):(.text+0x0): first defined here

collect2.exe: error: ld returned 1 exit status

exit status 1
Fehler beim Kompilieren für das Board Arduino Nano.


Könntest du bitte noch mal schauen ?

Ist aber nicht sooo eilig, habe dieser Tage div. Termine.

Morgen will ich meine Rente beantragen (ab 1.11.18 soll es soweit sein), Donnerstag nach Hannover Treffen ehemaliger Kollegen...…..

Schon mal Danke

Grüße Ingo


240 007-4
Regionalbahn (RB)
Beiträge: 26
Registriert: Mo 3. Sep 2018, 12:05
Nenngröße: H0
Stromart: digital
Steuerung: Multimaus, FRED, RocRail,Z21PG
Wohnort: Dresden
Deutschland

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#417

Beitrag von 240 007-4 » Mo 10. Sep 2018, 22:35

Hallo Ingo,

ich habe meinen Code seit der Version 4.79 stückweise angepasst und somit gibt es Abweichungen zum PG.
Ich habe zwar vesucht meinen Code mit dem PG abzugleichen, habe aber noch so einige Baustellen.
Die Strom/Spannung/Temp-Ausgabe aber Nebenbaustelle geworden und funktioniert sowieso noch nicht so recht.
Und da ist eben still und heimlich das #Define vom Z21DATADEBUG zum neuen Z21SYSTEMDATADEBUG geworden ...

Bitte nach

Code: Alles auswählen

#undef Z21DATADEBUG //to see DATA of Z21 LAN Protokoll

#undef Z21SYSTEMDATADEBUG  //to see the mainpower and temp
einfügen (das einzelne Auskommentieren geht natürlich auch).

Weiter zum nächsten Punkt. Bitte in Z21_Ethernet_DCC_Zentrale_v480.ino:

Code: Alles auswählen

/**************************************************************
XpressNet Master Interface*/
#define XPRESSNET  
#include <XpressNetMaster.h>
suchen und durch

Code: Alles auswählen

/**************************************************************
  XpressNet Master Interface*/
#if defined(__AVR_ATmega1280__) || defined(__AVR_ATmega2560__) //nur Arduino MEGA
#define XPRESSNET
#include <XpressNetMaster.h>
#endif
ersetzen. Den Hinweis hatte ich in der Zeile

Code: Alles auswählen

// UNinclude XpressNetMaster
////#include <XpressNetMaster.h> // auskommentieren
offensichtlich nur für mich lesbar versteckt :-)

Hoffe das geht jetzt und ich hab nicht noch mehr vergessen.

Viele Grüße
Uwe

Der heute ersteinmal ein Internetradio hat basteln müssen, da unsere tolle Landesregierung die Analogfrequenzen im Kabel per "Gesetz" (!!!) hat abschalten lassen :roll:
http://esp8266-server.de/Internetradio.html
Meine Z21-NANOESP Schaltung
Meine RailCOM-Erweiterung für Nano und meine Softwareanpassungen
"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)


Threadersteller
Ingolf
InterRegio (IR)
Beiträge: 156
Registriert: So 30. Aug 2015, 10:15
Nenngröße: H0
Stromart: digital
Steuerung: Z21
Gleise: Piko A
Wohnort: 39629 Bismark
Alter: 63
Deutschland

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#418

Beitrag von Ingolf » Di 11. Sep 2018, 14:26

Hallo Uwe,

hat sich ohne Fehlermeldung kompilieren lassen. Danke dafür. Fehlt bloß noch der TLE.
Werde nachher nochmal meine Platine überprüfen und dann mal probieren. (Ohne den Step-Up)

Dein Internetradio sieht interessant aus, die Abschaltung steht uns noch bevor.

Danke und Grüße

Ingo

Ab 1.11.18 bin ich Rentner !


Threadersteller
Ingolf
InterRegio (IR)
Beiträge: 156
Registriert: So 30. Aug 2015, 10:15
Nenngröße: H0
Stromart: digital
Steuerung: Z21
Gleise: Piko A
Wohnort: 39629 Bismark
Alter: 63
Deutschland

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#419

Beitrag von Ingolf » Di 11. Sep 2018, 15:42

Hallo Uwe,

läuft !
Ich komme auf die 192.168.0.111, kann die SSID ändern und von der App aus die LED (Gleisspannung) schalten.

Super. :D :D :D

Grüße Ingo


Threadersteller
Ingolf
InterRegio (IR)
Beiträge: 156
Registriert: So 30. Aug 2015, 10:15
Nenngröße: H0
Stromart: digital
Steuerung: Z21
Gleise: Piko A
Wohnort: 39629 Bismark
Alter: 63
Deutschland

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#420

Beitrag von Ingolf » Mi 19. Sep 2018, 07:49

Hallo zusammen,

Gestern habe ich es endlich geschafft, den kleinen Testaufbau fertig zu stellen. Wird sich auf der nächsten Börse in 3 Wochen sicher gut machen.

Bild


Angeregt wurde das Ganze von Uwe, der auch freundlicherweise den Schaltplan und die geänderten Dateien für den Sketch zur Verfügung
gestellt hat. Der Sketch basiert auf Philipps Version 4.79, geändert wurde die .ino-Datei und die MCU.h. Damit läuft der Sketch jetzt auch
auf einem Arduino Nano, allerdings natürlich ohne weitere I/O-Anschlüsse. Uwe hat noch einen Loconet-Anschluß für einen Handregler auf
seinem Board, habe ich auch noch weg gelassen, ich fahre über Handy oder TAB.

Bild

In dem Sockel für den Nano befinden sich die 3 Widerstände für den TLE, links noch ein Elko und ein 100n an der Stromversorgung. Der rechte
Elko ist für die 3,3V des ESP. Unter dem Sockel für das ESP-Modul befindet sich der 3,3V-Regler, unter diesem noch ein Widerstand, der zur
ESP-Beschaltung gehört. Die kleine Drossel liegt in der Zuleitung zum Step-Up-Modul. Die grüne Buchse habe ich mit eingelötet, falls ich doch
mal ans große Testgleis will.

Bild

Bild

Bild

Bild

Bild

Die Powerbank ist auch aus Einzelteilen zusammengesetzt, das Gehäuse mit Elektronik gab es mal bei FC (5 Stck. für knapp 5€) eingesetzt habe
ich einen 18650 Akku, soll haben 4200 mAh. Die Stromaufnahme der Schaltung beträgt ca 140 mA, mit fahrender Lok mit Motorsound werden
es ca 400 mA.
Sollte also wirklich für stundenlangen Spaß sorgen.
Die Powerbank wird noch mit Klettband befestigt.

So nun noch der Sketch.

Grüße Ingo
Z21_micro_479.zip
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.


andreas21
InterRegio (IR)
Beiträge: 180
Registriert: Fr 6. Jul 2018, 05:50
Nenngröße: TT
Stromart: digital
Steuerung: z21 & selectrix
Gleise: Modellgleis Tillig
Wohnort: Potsdam
Alter: 54
Deutschland

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#421

Beitrag von andreas21 » Di 9. Okt 2018, 23:30

Hallo Uwe,

danke für die Inspiration, den Bau eines Programmiergleis.
Auch ich habe mir jetzt eine kleine Zentrale zum Programmieren aufgebaut. Für den Aufbau habe ich den Schaltplan der Zentrale genutzt. (ohne S88)
Das Netzwerkmodul braucht schon etwa 140 mA, der Aufbau ca. 300 mA, so sollte es mit Lok ca. 8h arbeiten. (mein Akku 5000 mAh)

Bild

Mit Eingebaut ist ein Railcom Display so kann ich die Adresse der Wagen oder Loks gleich lesen.
Wird auf dem Gleis ein Wert gelesen/geschrieben ist in der zweiten Zeile für ca. 10 sek. der CV-Wert zu sehen.

Bild

Bild

Viele Grüße
Andreas


240 007-4
Regionalbahn (RB)
Beiträge: 26
Registriert: Mo 3. Sep 2018, 12:05
Nenngröße: H0
Stromart: digital
Steuerung: Multimaus, FRED, RocRail,Z21PG
Wohnort: Dresden
Deutschland

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#422

Beitrag von 240 007-4 » Mi 10. Okt 2018, 19:40

Hallo in die Runde!

Während Ihr hier eine Zentrale nach der anderen bastelt :-) habe ich versucht meine NANO-Variante samt Software zu verbessern. Aber soweit entfernt sind meine Gedanken auf jeden Fall nicht. Das Projekt hat ja eine Eigendynamik entwickelt ... Wahnsinn!!! Aber nun der Reihe nach.

Angespornt durch die vielen Mitbastler hatte ich meine etwas ins Stocken geratene Basteltätigkeit wieder aufgenommen :-) Begeistert vom RC-Auslesen meiner MEGA-Variante wuchs bei mir der Wunsch das bei meiner NANO-Variante auch umzusetzen. Ziel war insbesondere mit der mobilen Variante auf dem Basteltisch bevorzugt CVs schreiben und lesen zu können. Nebenher sollten einfache Funktionstests von Licht und Sound möglich sein. Ebenso sollte das LocoNet für das Dispatchen der Freds und Tests genutzt werden können.

Platz für die RC-Platine war noch ggf. zu Lasten einer großen Powerbank. Programmspeicher reicht. RAM ist ggf. etwas knapp, reicht aber. Ein schwieriges Problen stellte jedoch der Mangel an seriellen Schnittstellen dar. SoftSerial scheidet aus da Timer und Interupt mit dem LocoNet kollidieren. Als einzige Möglichkeit sah ich eine Mehrfachnutzung der einzigen HardwareSerial des NANO - umschaltbar für Wifi und RC über zwei Ausgabepins. Erste Versuche an der MEGA-Version waren viel versprechend. Gemeinsame Kommunikationsgeschwindigkeit muss dazu auf 250.000 BPS festgelegt werden. Der WLAN-Sketch wurde entsprechend erweitert, so dass auch diese Übertragungsrate erkannt wird. Der Logikbaustein wurde als 4x NAND + 2 Dioden zu einer Umschaltlogik erweitert. Wifi-Pakete nach der CV-Abfrage werden solange ignoriert bis die Antwort der Lok ausgelesen ist. Mit der Roco-App und RocRail funktioniert das problemlos.

Bild

Bild

Bild

Bild

Bild

Bild

Kurze Erklärung und Hinweis zum Verständnis 2018-10-27:
Der NANO hat nur einen einzigen HardwareSerial. Daher läuft RailCom und Wifi mit 250000 Baud (RailCom typisch) über einen Rx-Eingang des NANO! Bitte nur meinen ESP_V27 verwenden nur dieser kann 250000 Baud!

Es funktionierte anfänglich zwar im Prinzip, jedoch nicht sicher. Jede Menge falsche Werte zwischen den Richtigen. Verschiedene Softwareanpassungen wurden getestet. Unter Anderem sollten die Häufigkeit richtige von zufälligen falschen Werten unterscheiden können. An sich kein schlechter Gedanke jedoch anfangs wieder mit mäßigem Erfolg. Nach einer verordneten Motivations- und Sommerpause wurde dann, nicht zuletzt durch diesen Treat angespornt, die Arbeit wieder aufgenommen, der zu hohe Pull-Up-Widerstand (100k) auf der RC-Platine als mögliche Fehlerursache erkannt und gegen einen 10k ersetzt. Erfolg nach anfänglicher Euphorie jedoch immer noch bescheiden. Erst die Idee es mit der oben beschiebenen Softwareanpassung zu verknüpfen brachte den entscheidenden Erfolg. Noch ein paar keinere Softwareanpassungen und das RC-CV-Auslesen geht recht zügig und sicher. Zum Testen und Debuggen (eine serielle Debug-Schnittstelle ist nun beim besten Willen nicht mehr da :-) wurde ein kleines Display ergänzt. Dieses sollte nun auch noch reaktiviert werden und zur Anzeige der gerade erfolgten CV-Lese/Schreiboperation und ggf. mehr dienen (siehe Bild). Weitere Ideen, die Adresse über RailCom gleich auszulesen oder die einem FRED zugewiesene Adresse anzuzeigen, könnten folgen, werden aber erstmal von nachfolgender Software-/Speicherproblematik ausgebremst :-(

Bild

Bei all den Versuchen war anfangs testweise das LocoNet deaktiviert worden. Der Versuch es wieder mit zu implementieren zeigte die ausgereizten Speichergrenzen (RAM). Es ging entweder LocoNet oder RailCom mit Display. Zwei NANOs zum umstecken schien als Lösung möglich jedoch sehr unkomfortabel. Gedanken ein anderes Bord zu nehmen wurden verworfen, da entweder immer noch zu groß und nicht pinkompatibel (Arduino Mega 2560 PRO MINI ) oder wegen eines inkompatiblen Prozessortyps (Arduino Micro mit ATmega 32U4) auch nicht wirklich eine schnelle Lösung. Blieben also nur Versuche die RAM-Nutzung zu verringern. Display-Texte und Die RailCom-Decodieung wurden als große Speicherfresser in das PROGMEM verlagert - Plötzlich wieder über 300 Byte frei ...

Jetzt geht zwar LocoNet, RailCom und Display. LocoNet und RailCom scheinen sich jedoch etwas zu behindern. Bei aktivem LocoNet geht RailCom, jedoch sehr langsam (also viele Fehlversuche). Möglicherweise ein Timerproblem oder gar noch eine Specherverletzung? Oder doch zu wenig RAM? Als Abhilfe kann über die Pseudo-Lok 9999 und die Funktion F9 das LocoNet online über die Z21-App abgeschaltet werden. Somit sind ersteinmal alle Anforderungen erfüllt an die kleine Testkiste erfüllt :-)
2018-10-14: Ist nicht mehr erforderlich. Wifi-Lesefunktion wird bei RC-Aktivität abgeschaltet.

Kleiner Exkurs noch zum Thema CV-Auslesen. Da ich wie andere auch Probleme mit dem CV-Lesen hatte habe ich einerseits eine kleine Verzögerung zur Verbesserung des Timings im DCCPacketScheduler eingebaut und andererseits die Referenzspannung (ARef) auf 1,1 V gesetzt. Der Mega unterstützt das von Haus (INTERNAL1V1) aus. Der Nano benötigt einen 62k-Widerstand zwischen 3,3V und dem Eingang AREF den ich gleich als SMD auf die Lochrasterplatine von unten an die benachbarten Pins gelötet habe und die Einstellung --> analogReference(EXTERNAL);
Mit dieser kleinen Hardwareergänzung lassen sich alle Arduinos, wie von PG ursprünglich wohl mal vorgesehen, mit einer Referenzspannung von 1,1 V und somit genauer betreiben.

Diese Anpassung zieht natürlich neben der CV-Auslesung Anpassungen hinsichtlich Kurzschlussstrom, Strom, Spannungs und Temperaturmessungen nach sich. Leztere habe ich mit einem auf 30k eingestelltem Poti an 5 V und einem 15 k-NTC parallel mit einem 10 k gen GND schaltungstechnisch realisiert: 5V - 30k - (temp) - (10k||Epcos-NTC-15k) - GND
Mit der einfachen Skalierung temp = (1023-temp) *100/1000; in Z21_LAN.h ergibt sich zwischen 0-80°C ein weitgehend linearer Verlauf.

Mit dieser Anpassung habe ich Testreihen mit über 10.000 fehlerfreien CV-Lesevorgängen erreicht. Durch dieses Thema hier bin ich auf die Zusatzbeschaltung mit 10k und 100nF (C4 und R17) gekommen. Allein der 10k-Widerstand reicht das Auslesen zuverlässiger mit meiner Softwareanpassung schneller zu machen. Pro CV brauche ich jetzt ca. 2 bis 4 Sekunden - und das ist doch super.

Den 62k-Widerstand und R17(10k) habe ich weiter vorn im NANO-Schaltplan ergänzt.

Im Übrigen, bei meinen Tests zeigte sich, wenn C8/R36 mit beschaltet wird ist auf jeden Fall auch C4 erforderlich. Also entweder nur R17 oder
C4+R17+C8+R36.

2018-10-21 Hinsichtlich verlorener UDP-Nachrichten beim CV-Auslesen:
RocRail wurde angepasst und versteht nun auch "unverlangt" oder zur Unzeit erhaltene CV-Rückmeldungen. Somit kann die Z21PG auch entsprechend agieren und ein "Read all" läuft durch. Ich habe das mein Z21PG-Programm soweit ergänzt, dass - falls nicht eine erneute CV-Abfrage erfolgt - der CV-Wert ein zweites mal nach 15s und nach weiteren 15s der Folgewert an RocRail etc. gesendet wird ("#define RCREADREPEAT").

Ergänzung 2018-10-27:
Ohne OLEDDISPLAY bitte folgende Zeile "#define OLEDDISPLAY" unbedingt auskommentieren, an der richtigen Stelle! - ggf. mehrfach ...
Es geht sonst NICHTS OHNE Display! OLEDDISPLAY verzögert übrigens das CV-Lesen (ca. 1,5 fach) und ggf. auch andere Funktionen.

Ich versuche immer mal den aktualisierten Code als zip hochzuladen. Die Änderungen können leicht im Vergleich, z. B. mit WinMerge, mit der PG-Version 4.80 vom 6.3.2018 nachvollzogen werden.

Vielleicht habe ich ja das Interesse geweckt die Softwareanpassungen mal auszutesten.

Viele Grüße
Uwe

Änderungen:
2018-10-12 Schaltplan NANO mit Anschlüssen OLED-Display, RC-Erweiterung ergäntzt
2018-10-14 Fehlerbereinigte Software hochgeladen, jetzt mit besser funktionierendem Display, Dispatch-Meldung, LN-Reglererkennung
Lokadresse wird jetzt sekündlich aus den RC-Daten ausgelesen und angezeigt (Das war der Plan von Anfang an :-))
2018-10-21 Zwei RC-Loks mit gleichen (ZIMO-)Decodern bringen über den Broadcast (Block A) abwechselnd die Adresse zur Anzeige. Ein Zimo und ein ESU-Decoder lassen (wie erwartet) das auslesen kollabieren. Es wird sogar eine Datagramm-Antwort (Block B) interpretiert. Hier muss ich wohl bei Gelegenheit die Interpretation untersuchen.
2018-10-30 Überarbeiteter Softwarestand (Zimo und ESU-Decoder zeigen jetzt auch mehr oder weniger abwechselnd ihre Adresse), getestet auch auf MEGA, - kein kollabieren des RC

Meine Z21PG-Bastelprojekte allgemein
Meine Z21-NANOESP Schaltung

Software vom 2018-10-10 fehlerhaft, gelöscht! (12 Downloads)
Software vom 2018-10-14 nur noch informativ, überarbeitet und in Kürze gelöscht!
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Zuletzt geändert von 240 007-4 am Mi 31. Okt 2018, 08:06, insgesamt 10-mal geändert.


Threadersteller
Ingolf
InterRegio (IR)
Beiträge: 156
Registriert: So 30. Aug 2015, 10:15
Nenngröße: H0
Stromart: digital
Steuerung: Z21
Gleise: Piko A
Wohnort: 39629 Bismark
Alter: 63
Deutschland

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#423

Beitrag von Ingolf » Do 11. Okt 2018, 08:18

Jungs, Waaaahnsinn, was ihr da zusammenbaut.
Und dann auch noch allen zur Verfügung stellt !

Um diese Sachen weiter zu entwickeln, fehlen mir einfach die Grundkenntnisse.
Allerhöchsten Respekt !

@Andreas21
Ich vermute, du speist die Powerbank in die USB-Buchse des Mega ein ? Ist nicht so genau zu erkennen.
Railcom Display nach Paco ?

@Uwe
Deinen neuen Beitrag muß ich mir vermutlich noch mehrmals durchlesen, bis ich alles begriffen habe.
Mit meiner Variante (deine Ursprüngliche) habe ich in der Tat 2 kleine Probleme.
Als erstes mußte ich eine leistungsstärkere Powerbank verwenden, bei fahrender Lok mit Sound und dann noch das Horn --> hier hat dann
die Powerbank dicht gemacht. Mit der neuen Powerbank keine Probleme mehr.

CV lesen geht nicht bei allen Loks. Im Club eine ältere Lok, Decoder unbekannt, überhaupt keine Reaktion.
2 meiner Loks haben einen ESU Loksound 4, hier funktioniert alles wunderbar.
Eine 3. Lok hat einen älteren (ca 5 Jahre) alten Uhlenbrock-Decoder, hier kriege ich meist nur falsche Werte ausgelesen.

Sonntag haben wir Börse, da brauche ich das Teil, sonst hätte ich mich gleich an den Umbau auf deine Neuerungen gemacht, vermute aber,
das schaffe ich nicht mehr.

Danke und Anerkennung für eure Arbeit

Grüße Ingo


andreas21
InterRegio (IR)
Beiträge: 180
Registriert: Fr 6. Jul 2018, 05:50
Nenngröße: TT
Stromart: digital
Steuerung: z21 & selectrix
Gleise: Modellgleis Tillig
Wohnort: Potsdam
Alter: 54
Deutschland

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#424

Beitrag von andreas21 » Do 11. Okt 2018, 20:49

Hallo Ingo,

mein Aufbau ist ein erster Test und ich möchte ihn noch verbessern.
Die Powerbank ist an einer USB-B Buchse angeschlossen, nicht am Mega 2560. Auf der Platine ist auch der Start/Stop Taster und ein Anschluss für den Schalter. Auf dieser Seite der Schachtel ist auch der CDE-Booster Anschluss / Gleisanschluss, XpressNet, Roco-Booster und LocoNet-Anschluss.
Die Buchsen vom Mega 2560 habe ich ausgebaut. Auf der anderen Seite ist nur die LAN-Buchse und die drei LEDs.
Das Railcom Display ist das von Paco mit einigen Änderungen.

Bild

Die Zentrale etwas kleiner aufzubauen hatte ich auch schon einmal begonnen. Beim Auslesen der CVs gab es immer die gleiche Zahl 255 und dann habe ich diesen Aufbau erst einmal zur Seite gelegt. Mit den Erfahrungen und Tips von Uwe werde ich hier noch mal weiter testen.

Bild

Viele Grüße
Andreas


Threadersteller
Ingolf
InterRegio (IR)
Beiträge: 156
Registriert: So 30. Aug 2015, 10:15
Nenngröße: H0
Stromart: digital
Steuerung: Z21
Gleise: Piko A
Wohnort: 39629 Bismark
Alter: 63
Deutschland

Re: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#425

Beitrag von Ingolf » Do 18. Okt 2018, 09:46

Hallo Freunde,

Gestern habe ich die Zentrale in dem Pollin-Gehäuse fertig bekommen.
Software 4.80 und ESP-Soft v28 nach PG.
Funktioniert sehr gut, Loks fahren, CV und Railcom funktionieren auch. Prima. Mein Dank an alle Mitwirkenden.

Peripherie konnte ich noch nicht testen, kommt, wenn vorhanden.

Bild

Bild

Bild

Bild

Bild

Bild

Grüße Ingo

Antworten

Zurück zu „Software und Hardware“